1

I'm dual-booting Ubuntu 14.04 and Windows 10. I accidentally deleted the partition table for my main HDD, but was able to recover it. Now, I can't boot Windows. Thankfully, it was easy to reinstall Grub and boot Ubuntu.

When trying to boot Windows, there is an error message on a bright blue screen:

A required device isn't connected or can't be accessed.

Error code 0xc0000225

I tried pressing F8 for Startup Settings, but got this error:

The application or operating system couldn't be loaded because a required file is missing or contains errors.

File: \Windows\system32\winload.efi

Error code: 0xc0000225

I have already made a Windows install USB and tried using the recovery tools on it. Startup Repair didn't do anything at all. System Restore said to restart then select the OS but nothing happened after restart. Based on instructions here I went to CMD and ran bootrec /rebuildbcd, which found my Windows install, but when I confirmed to add it to the boot list, it said something like the drive was inaccessible.

Edit: Changed some details above. Also retried the install USB but now it won't even start. It errors:

Your PC/device needs to be repaired. The boot configuration data for your PC is missing or contains errors.

File: \EFI\Microsoft\Boot\BCD

Error code: 0xc000000f

Tomorrow, I will re-make the installation media then retry.

  • BTW this isn't urgent. I only use Windows for a few specific programs that don't run on Linux, and I have a Windows VM which works for most things. – wjandrea May 3 '16 at 2:56
  • I'm pretty surprised you can still boot into ubuntu after running windows startup repair - it typically blows it away and replaces it with the nt loader. Did you reinstall grub2 AFTER you trying the windows repair? Can grub see the boot partition and the main windows system partition correctly? – Argonauts May 3 '16 at 3:03
  • When I said Startup Repair did nothing, I meant it. It errored before it even started, something like "Could not repair startup". The Windows bootloader is in Grub's list. I can mount C: in Ubuntu. – wjandrea May 3 '16 at 3:13
  • I'm assuming you have an MBR Bios, not a EFI with this comment. Windows 10 creates 2 or 3 partitions during installation; 2 if you have an SSD, and 3 if you do not. These are the primary system partition "c:". a winre "recovery" partition around 450 MB in size, and a system reserved partition only on standard HDDs, but not on SSDs. The system reserved partition is where the bootloader lives if you have one (otherwise it's on the system drive). In either case the primary system partition must be the one flagged as 'boot'. Make sure it is still flagged. The WinRE part is a non factor with boot – Argonauts May 3 '16 at 3:50
  • I don't think it's BIOS. The computer came with Windows 8, which requires UEFI, no? – wjandrea May 3 '16 at 3:55
1

The solution was to boot an install disc, start a command prompt, then run bootrec /rebuildbcd

Edit (2016-06-16): Whoops, I forgot I had already tried that. I may have solved the problem by adding an msftdata flag to C: or by rebuilding the install disc, but I can't remember exactly what steps I took besides running bootrec /rebuildbcd

| improve this answer | |
1

I had a similar experienced with my Asus ROG GL552VW. Originally I would dual-boot Ubuntu 16.04 LTS and Windows 10 and everything was working fine until I restarted my computer with my External USB 2.5 Drive plugged in to my laptop (it contained a backup Asus ROG Windows 10 System). I think that my laptop attempted to boot from the External USB Drive and that is when I tried to stop it by pressing the power button. This screwed up my dual-boot setup.

When I restarted my laptop again I chose Windows from GRUB but I encountered the horrific blue error screen:

Your PC/device needs to be repaired.

The boot configuration data for your PC is missing or contains errors.

When I selected option F8, I received the message:

The application or operating system couldn't be loaded because a required file is missing or contains errors.

File: \Windows\system32\winload.efi

I did some research and after reading at this post I figured how to modify my UEFI/BIOS settings and fix my Windows 10 boot issue.

I read this Asus support forum to access my laptop's firmware. I booted the laptop and as soon as I saw the Asus splash screen, I pressed Esc multiple times. Then a boot menu screen loaded and I selected Enter Setup

I noticed the current settings in my firmware:

Security

Secure Boot Control [Disabled]

Boot

Launch CSM [Enabled]

Launch PXE OpROM [Disabled]

Next, I modified these settings to :

Security

Secure Boot Control [Enabled]

Boot

Fast Boot [Enabled]

Launch CSM [Disabled]

Then I restarted my computer and I booted from a Windows 10 Installation DVD. I used the recovery tools from Startup Repair. I entered CMD.

After running bootrec /RebuildBcd:

1 Windows installation was identified

When asked Add installation to boot list? I chose Yes

Finally it said The operation completed successfully

Restarted computer

I did not need to reinstall GRUB2. My laptop is now back to normal and I am able to dual boot to Ubuntu 16 and Windows 10! I hope people find this helpful :)

| improve this answer | |
0

Make a backup of your old config then try

sudo grub-mkconfig -o /boot/grub/grub.cfg

This will make a new config, and will probably add Windows back.

| improve this answer | |
  • The Windows bootloader shows up in Grub, that's not the issue. The Windows bootloader will not boot Windows. – wjandrea May 3 '16 at 3:10
  • msdn.microsoft.com/en-us/library/windows/desktop/… this error is ERROR_SEEK 25 (0x19) The drive cannot locate a specific area or track on the disk. Which referes to msdn.microsoft.com/en-us/library/ms837466.aspx, hope this helps a bit... – Alex May 3 '16 at 3:17
  • The code I saw was actually something like 0x0000025. Is that the same? – wjandrea May 3 '16 at 3:19
  • Please get the right error code, because 0x25 isn't in the list. – Alex May 3 '16 at 3:22
  • Have you tried bootrec /fixmbr and bootrec /fixboot too? After this you probably have to reinstall grub2 because Windows will overwrite grub2 most likely. – Alex May 3 '16 at 3:33
0

I have had many similar problems with Windows 10 systems blue screening on startup, including the 0xc000000f, but not the 0x0000225.

The solution that will save you the most time will be to reinstall Windows 10 - this will take a few hours and help you avoid continually rebooting the system only to find the same problems.

Download the Media Creation Tool for free: https://www.microsoft.com/en-gb/software-download/windows10 - Use this to create the installation disk/usb.

Use Ubuntu to backup your Windows Partition (excluding windows files), then restart and use the installation disk/usb to install Windows 10 to your chosen Windows 10 partition, formatting the partition in the process.

Again, while this may seem like a drastic measure to solve a missing or corrupt boot file, it will save you countless hours in the long run.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.