1

I'm under Windows 10 x64, and my problem is that when I insert a removable device (a smartphone) a Bluetooth related shortcut is created inside the SendTo folder (at C:\Users\{username}\AppData\Roaming\Microsoft\Windows\SendTo) ...even if I remove that shortcut, next time will be created again, and again, and again ...always the same dumb behavior of Windows.

That is one of the most annonying things that I can see, because I use custom shortcuts and I don't want to have an additional "Bluetooth" shortcut that I will never use, and also it increases x3 the width of the SendTo's contextmenu because the name of that damn shortcut is very more large (in my O.S language) than the other names of the other custom shortcuts I have in that folder.

My question is simple, how I could prevent Windows from creating the Bluetooth shortcut anymore?.

Please note that if the solution implies group policies usage, then I need the exact registry value that is set when applying that policy to be able reproduce the policy via regedit, instead of using the group policy manager user-interface.

1

I have found that hiding the SendTo short-cut solves your problem by making the short-cut invisible.

You should find the short-cut in %APPDATA%\Microsoft\Windows\SendTo\. Open cmd, then type:-

cd "%APPDATA%\Microsoft\Windows\SendTo"
attrib +r +h +s "BlueTooth ShortCut Name.lnk"

Setting read-only and system attributes should stop overwriting by an unhidden version. Note that in explorer the Properties are those of the link, not of the short-cut file itself, hence the need to use cmd.

0

Have you tried to disable the Bluetooth device in the device manager or disable the bluethooth service in the service control panel?

Run "services.msc" to open services control panel then disable the Bluetooth services.

0

For anyone else wandering across this page, I was stumped for quite a bit on this one.

I tried using Group PolicyUser ConfigurationPoliciesPreferencesWindows SettingsShortcutsDelete %SendToDir%\Bluetooth device, but that didn't work.

So I created a batch file and tried every combination under the sun to delete the file, but I just couldn't do it. However, I could delete the file manually as a regular user by going to %AppData%\Microsoft\Windows\SendTo\Bluetooth device and right-clicking delete, so I knew it wasn't a permissions issue.

I finally checked the Recycle Bin and noticed that the file had a different name there, Bluetooth File Transfer. So I went back to Group Policy→…→Shortcuts and told it to delete Bluetooth File Transfer in %SendToDir% and it finally worked!

For the user without Group Policy, create a .bat file, add the following, and put it in your startup menu:

IF EXIST "%AppData%\Microsoft\Windows\SendTo\Bluetooth File Transfer" (
 del "%AppData%\Microsoft\Windows\SendTo\Bluetooth File Transfer"
)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.