-1

This question already has an answer here:

I've a new modem and now my network connection is public and not private, on Win10.

I've read a lot of solutions, like this:

  • Go to homegroup, the is a link 'change network connection'. But there is no such link (in my case)
  • Go to the ethernet properties, there is a switch which let you set sharing on and off. But there is no such switch (in my case)

I'm running win10 pro.

marked as duplicate by Ramhound, Community May 3 '16 at 15:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • The following question's answers still apply to Windows 10. 1, 2, and 3 – Ramhound May 3 '16 at 14:17
  • Thanks for bringing up the obvious results (I am able to Google too), but as I said, these didn't work for me – Michel May 3 '16 at 14:26
  • I verified the steps, were accurate on my Windows 10 machine, before I submitted that comment. – Ramhound May 3 '16 at 14:27
  • @Ramhound, you're right, I missed one answer: superuser.com/questions/395606/… just below the accepted answer – Michel May 3 '16 at 14:54
  • @Michel- Perhaps in the future you will avoid submitting rude comments that make false assumptions. I did a considerable amount of research before I submitted that comment. – Ramhound May 3 '16 at 15:03
0

You can adjust this setting pretty easily from powershell.

  1. Open Powershell as admin and enable scripting

Start powershell as an admin (Hit start, type powershell, right click the icon and select 'run as administrator')

Make sure you have enabled script execution in powershell:

Set-ExecutionPolicy unrestricted

Select 'y' when prompted

  1. If you only have one active network connection (otherwise skip to 3)

If the connection you want to change from public to private is the only active connection this is simple; use the following commands

net = get-netconnectionprofile
Set-NetConnectionProfile -Name $net.Name -NetworkCategory Private

Go to step 4

  1. If you have multiple active connections, you can do it this way (in the admin powershell session):

Get-NetConnectionProfile

Copy down the output from that for the NAME field for the connection you want to change, and enter the following command into powershell, with NAME being replaced by the result from the last call. Keep the double quotes in the powershell command. e.g. if the network name was argonautsNet, use "argonautsNet"

Set-NetConnectionProfile -Name "NAME" -NetworkCategory Private
  1. You can verify that setting 'took' from powershell with this command, look for the ethernet interface you changed (or there will be only one listed if you did it by step 2's instructions)

Get-NetConnectionProfile

If this doesn't work, post the error messages / codes that you receive in the powershell session. This can be done with registry mods as well.

Edit - I am assuming you already tried the standard methods via the settings GUI, etc, which are linked to in comments to your question.

Not the answer you're looking for? Browse other questions tagged or ask your own question.