3

I've installed VS Code in Ubuntu 14.04 LTS. When using it, it always sits on top of other windows. Not only does it sit on top of other applications like the terminal, it also sits on top of its own dialogs (like for opening a file):

enter image description here

Is there some sort of weird interaction between the API that VS Code is using and the X server that might be causing this? How can it be fixed?

Note that this is not the same as this question, which concerns Visual Studio (not VS Code) on Windows.

  • So if you get rid of X Server, does this behavior, still exhbit itself? – Ramhound May 3 '16 at 18:09
  • I tried getting rid of X server but then my window manager stops working. – Andrew Mao May 3 '16 at 18:15
  • Is this a virtual machine, or installed directly? I did find this issue with VirtualBox, where OpenGL windows are on top of other windows in Linux guests. But I'm unsure if this applies here. – Cory Shay May 3 '16 at 18:56
  • @CoryShay yes, this is in VirtualBox! So if the problem is that it is using OpenGL, is there any workaround? – Andrew Mao May 3 '16 at 19:05
  • @AndrewMao According to the issue it appears for some they were able to get around it by doing export LIBGL_ALWAYS_SOFTWARE=1 which you should be able to place within your ~/.profile. – Cory Shay May 3 '16 at 19:08
1

I started seeing this issue after I installed Guest Additions updates to the VirtualBox. I tried setting the LIBGL_ALWAYS_SOFTWARE env var but that didn't seem to fix it for me. Finally, I ending up reinstalling the Guest Additions and that ended up fixing it.

0

It's possibly you have accidentally set it to be "Always on Top", which it appears according to this answer you may be able to get to using "Alt+SPACE"--which will bring up the right click menu-- and then T for "Always on Top". If it is selected it should deselect the option. Otherwise you should be able to right click on the top border and get the same options.

  • Thanks for the suggestion. Always on Top is not checked, but it still appears on top. If I check it, the title bar disappears completely. – Andrew Mao May 3 '16 at 18:45
  • That's really weird. Haven't ever seen this issue, I will try once on a vm to see if I can replicate. – Cory Shay May 3 '16 at 18:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.