I am missing the run command from my computer. I do not mean from the menu. I mean the actual exe seems to be gone. I can type run in the search field on the Start Menu and it shows the Desktop App icon but if I click it nothing happens. If I press Windows+R nothing happens.

I never get an error or anything it just doesn't launch the run prompt dialog box. I am on Windows 10 Pro Insider Preview build number 14295.1000. I run Avast Anti-Virus.

My only theory at this point is that Avast falsely identified the exe as a virus and deleted it. Can anyone tell me how to go about repairing this issue, please? I tried to Google it but all I get are countless articles on how to add Run to the Start Menu.

  • 2
    There is no run.exe
    – DavidPostill
    May 3, 2016 at 17:59
  • 2
    Sounds like you should reset your installation, based on the description, your installation is hosed. As correctly pointed out, there is no "run.exe" it has never existed, I suspect you just have a incompatible program installed.
    – Ramhound
    May 3, 2016 at 18:04
  • Run is an extension of Explorer.exe, task manager will show this.
    – Moab
    May 3, 2016 at 18:22
  • 2
    in general, if you suspect some of your system files are corrupted (or deleted by antivirus), running dism restorehealth followed by sfc scannow should fix it in Win8.1+. (you may need your install media or a working Internet connection to Windows Update to download the missing/corrupted files, though) -> see support.microsoft.com/en-us/kb/947821
    – mihi
    May 3, 2016 at 19:32

1 Answer 1


since there is a third party security application on your system. we could boot into clean boot then press Windows+R again to have a test in case it is blocked by third party security application . https://support.microsoft.com/en-us/kb/929135

if the issue persists, your current system files might be corrupted. Please try to scan and restore your current system component using "DISM"command. dism /online /cleanup-image /restorehealth

If above method doesn’t work. I suggest to execute a system restore, this way can restore your system to a previous healthy state which can resolve present problems.

Best regards

  • 1
    Avast was causing this issue.
    – mpmackenna
    May 5, 2016 at 18:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.