3

I upgraded to Windows 10 since a week, the first issue that disappointed me is this mouse freezing when I'm typing.

I googled two days, trying all solutions, nothing worked.

I have ELAN device with its tab in the Mouse property dialog

Solution 1 : Downgraded the driver

I downgraded the driver of the mouse, after restarted nothing changed

Solution 2 : Uninstall and Re-install (I don't recommend)

That was catastrophic for me; after restarted, the keyboard and mouse were off, I had their Big picture with their big hour ...

Auto repaire didn't work, Safe Mode same things keyboard and mouse off

I fixed this by using a USB mouse and the virtual keyboard which made me crazy before working well (finally I found that the virtual keyboard don't work well when the physic one is off)

Solution 3 : Update to driver

I did, nothing changed

I observed that MS Word wasn't affected by that issue, I also tried to see why not Visual Studio or any other text editor ?

Perhaps someone can help me here, the solutions I shared may help other people

2
  • Similar just now: windows update -> no keyboard/touchpad -> automatic repair -> system restore -> very long wait -> still no keyboard/touchpad despite restore to a time prior to when mouse/keyboard was working! During system restore, keyboard/touchpad were clearly working, so driver is implicated. Will report answer when I find one...
    – omatai
    Jun 11, 2021 at 2:25
  • Thanks for report. May be new Win10 drivers because standards or generics are more safe. You could try the manufacture one.
    – Fabrice T
    Nov 20, 2021 at 5:15

2 Answers 2

2

I finally found a working solution myself:

There are two methods
1. The long (the one I did) which doesn't need computer restart
2. Short (the one I advice) which need computer restart

Solution 1.
Start RegEdit
Go to HKEY_CURRENT_USER\SOFTWARE\Elantech\SmartPadDisplay
Set TouchPadRejection_Display to 1
Double-click on ELAN Pointing Device icon in the system tray area
Go to the third tab Additional then TP Reject
Then uncheck Active
Then Ok, you are done

Solution 2.
Start RegEdit
Go to HKEY_CURRENT_USER\SOFTWARE\Elantech\SmartPad
set DisableWhenType_Enable to 0
Restart the PC, you are done

Now I found back my win7 mouse.

Sorry if I made any expression mistake, I am French as same as my computer

0

Don't forget to just try enabling the touchpad with: Fn+F7. That's what solved the problem for me after going down the drivers/registry hacks rabbit hole.

http://www.tomsguide.com/answers/id-2008118/wont-cursor-move-acer-laptop.html

1
  • In my PC it is fn+F1, this could help others
    – Fabrice T
    Dec 11, 2017 at 16:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .