0

After clicking on a magnet link (for example one at: https://www.openoffice.org/distribution/p2p/magnet.html) Chrome will show the usual "external protocol request" dialog where it asks whether to start the application associated with the protocol or to do nothing.

I choose "start application" but nothing happens. Tried with uninstalling and reinstalling Chrome, running with all extensions disabled, tried incognito mode, tried uninstalling and reinstalling the torrent client, tried installing a different torrent client. Nothing will help. In the latter case (installing a different torrent client) Chrome will reflect that in the external protocol request dialog box (saying that it will launch the new torrent client) but again nothing happens at all.

This has nothing to do with resetting the handling of magnet protocol in "Local State" file, because Chrome it's actually handling it, but then it doesn't start the application.

Chrome version: 50.0.2661.94 m

Running on: Windows 7 64bit

0
0

The answer above did not work for me. But this one worked: (dont upvote my answer but his).

Simply:

1) Goto URL chrome://settings/clearBrowserData

2) Select duration "Past week".

3) Select only "Cookies and other site data"

4) Click "Clear Browsing Data" and browse site again.

0

This similar question Chrome Magnet Links Won't Launch (Windows 7) helped me fix it! In my case too, the source of the problem was that, long ago, I decided to reinstall Shareaza to see if the Gnutella network was still being used and quickly uninstalled it, but for some reason, it had permanently messed up with the handling of the magnet protocol in the Chrome.

So, as it was recommended in this answer to that similar question, I went through the registry, deleting every key that contained "Shareaza" in it, and now finally the problem is solved.

1
  • I only could find that one similar question after starting to ask a question myself and typing the title for it (suggested similar questions). Before that, I spent ages googling for this problem, without reaching the other question, so maybe it can be helpful to keep both of them alive. – jj_ May 4 '16 at 4:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.