0

I am getting the following error while trying to connect to FTP server deployed on my Azure VM.

Warning: Selected port (18183) is not the default port (21) of the selected protocol.
Warning: The entered address does not resolve to an IPv6 address.
Status: Connected, waiting for welcome message...
Reply: 220-FileZilla Server 0.9.56 beta
Reply: 220-written by Tim Kosse (tim.kosse@filezilla-project.org)
Reply: 220 Please visit https://filezilla-project.org/
Command: CLNT https://ftptest.net on behalf of 168.63.97.45
Reply: 200 Don't care
Command: AUTH TLS
Reply: 234 Using authentication type TLS
Status: Performing TLS handshake...
Status: TLS handshake successful, verifying certificate...
Command: USER Usera
Reply: 331 Password required for rheinenergie-klima
Command: PASS **********************
Reply: 230 Logged on
Command: SYST
Reply: 215 UNIX emulated by FileZilla
Command: FEAT
Reply: 211-Features:
Reply: MDTM
Reply: REST STREAM
Reply: SIZE
Reply: MLST type*;size*;modify*;
Reply: MLSD
Reply: AUTH SSL
Reply: AUTH TLS
Reply: PROT
Reply: PBSZ
Reply: UTF8
Reply: CLNT
Reply: MFMT
Reply: EPSV
Reply: EPRT
Reply: 211 End
Command: PBSZ 0
Reply: 200 PBSZ=0
Command: PROT P
Reply: 200 Protection level set to P
Command: PWD
Reply: 257 "/" is current directory.
Status: Current path is /
Command: TYPE I
Reply: 200 Type set to I
Command: PASV
Reply: 227 Entering Passive Mode (100,113,144,72,210,89)
Command: MLSD
Reply: 425 Can't open data connection for transfer of "/"
Error: Listing failed

I tried looking on several forums, but could not find a concrete answer. So far I have tried it in active as well as passive mode and testing it via https://ftptest.net.

I have my FTP over TLS enable and I have generated the certificate too.

Inbound rules for my port (18183 has been added too).

Note: I am not using the port suggested by the FileZilla server.

  • Are you connect as standard (insecure) FTP? What OS is the server? – Burgi May 26 '16 at 14:49
0

The error log you provide shows your FTP client is connecting to the FTP server using passive mode.

In this mode, the FTP client uses 2 channels:

  • The control channel (listening on port 18183 in your case), to give commands to the server
  • The data channel (listening on ports 100,113,144,72,210,89 as shown by the PASV command), to send/received data

This 2 channels mode allows to still be able to give commands while sending/receiving data.

In your case, I suspect some ports in your VM and/or Network Security Group (if you use one) are not open. So you need to create either the corresponding ACL (Access Control List) or update your inbound rules in the Network Security Group associated with your VM to allow TCP access on ports 100,113,144,72,210,89.

0

we are having the same problem too as our azure RM vms are behind an internet load balancer in an avset and all the NSG rules are open on the specific ports, windows firewall off. The correct definition of data channel port see http://www.serv-u.com/respcode.asp?resp=227

Error: You appear to be behind a NAT router. Please configure the passive mode settings and forward a range of ports in your router.

Answer: I got it to work using filezilla server by adding NAT rules on the load balancer on the same port as the data channel port range. You can also use PS for this too $LoadBalancer | Add-AzureRmLoadBalancerInboundNatRuleConfig -Name $NatRuleName -FrontendIpConfiguration $frontendIP1 -IdleTimeoutInMinutes 4 -Protocol TCP -FrontendPort 5000 -BackendPort 5000 | Set-AzureRmLoadBalancer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.