0

I want to configure and install BurpSuite on Windows 8. I downloaded the latest version from their Website . I installed it, then i configured firefox - (see this) https://www.dropbox.com/s/4pwdcrkgmqlcd6n/1.png?dl=0

But as soon as i did this, no website opened. I followed everything that this website told me to do - http://shield4you.blogspot.in/2015/01/set-up-burp-suite-in-proxy-environment.html See Img 2- https://www.dropbox.com/s/yjbfjh2yej8mrgl/2.png?dl=0

The website says Options but there are 2 options in the new version of BurpSuite "Project Options" and "User Options". Which one do I choose? Both have Upstream Proxy Servers.

See Img 3- https://www.dropbox.com/s/d8db9c63q1yk07i/3.png?dl=0 I have configured both of them. Still the Internet is not working in Firefox.

What do I do? Please explain with images.

Intercept is on and when i click on forward connections, this is what i get when i click forward on BurpSuite: See image 4- https://www.dropbox.com/s/osjn7vt4yktdtyk/4.png?dl=0

Note I have already read this post so don't redirect me to this one - https://security.stackexchange.com/questions/63158/how-to-configure-burp-suite-in-browsers-while-my-internet-connection-works-behin

migrated from security.stackexchange.com May 4 '16 at 16:52

This question came from our site for information security professionals.

  • 1
    None of your image links work. You should upload them to i.stack.imgur.com instead of your Dropbox account. – Ramhound May 4 '16 at 17:09
  • All images are working man ,check them again ! All are working in here.Check again.They always were working . Anyways this question has been solved – ErrorrrDetector May 4 '16 at 20:17
  • 1
    They don't work for me. My suggestion is a good one, if you take it, you no longer have to share files from your own Dropbox account – Ramhound May 4 '16 at 21:38
1

This is because you are trying to access site which is protected by HSTS using Invalid certificate, In your Browser's Proxy settings add manual proxy like 127.0.0.1 and Port 8080 than open your Burp suite First go to Proxy -> Options, Add a Field called 127.0.0.1 with Port 8080, Similarly add *:443 and *:80 with Enable Invisible proxying Ticked and than in your browser type http://burp , click on Download CA certificate, After downloading, Go to

Options -> Preferences -> Certificates

and Import your Downloaded CA Certificate, than Restart the Burp and Browser and you would be able to solve your issue.

  • I had already done that . – ErrorrrDetector May 4 '16 at 16:47
  • The problem has been solved i had to download the certificate from Burp Suite 's Proxy> Options then Export a certificate from there and import it in Firefox . Thnx for hinting me with that.The new Version of Burp Suite generates a new certificate each time it is loaded . Stay Advised man – ErrorrrDetector May 4 '16 at 16:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.