3

I have a Fujitsu NH532 with 3 USB 3.0 ports running Windows 8.1.

My problem is that none of the blue USB 3.0 ports is operating at 3.0 speed. Whichever USB 3.0 device I plug in, the Devices and Printers page in the Control Panel puts a remark that the "device would work faster if plugged into a 3.0 port".

All the latest Fujitsu drivers from their page are installed (it's using Intel USB 3.0 eXtensible Host Controller driver by Microsoft), latest BIOS version too, and looking at the Device Manager, I can see the USB Root Hub (xHCI) shown at the bottom, but with a couple of "Generic USB" hubs which seem to operate at 2.0. This is how the page looks like with a USB 3.0 flash drive plugged in (there are two Mass Storage devices, presumably the other one is just the built-in card reader).

USB controllers

When I plug in a device, I can find it in the properties for one the Generic USB Hubs at the top:

enter image description here

Note the "Hub is operating at high-speed" message.

enter image description here

On the other hand, properties for the xHCI hub don't show any tabs regarding connected devices:

enter image description here

Did anyone have a similar problem and found a way to resolve it?

(Update) - Added a snapshot of the devices sorted by connection, as suggested by @BenVoigt:

Devices by connection

This indeed shows that the USB 3.0 mass storage device is not connected under the eXtensible Host Controller.

  • "View Devices By Connection" is a lot more helpful for solving these sorts of problems than "View Devices by Type" – Ben Voigt Jan 2 '17 at 22:28
  • @BenVoigt: Thanks for the suggestion, I have updated the question. – Groo Jan 3 '17 at 8:10
  • Ensure that the device is plugged in the correct port. – juniorRubyist Jan 4 '17 at 5:30
1

Some remarks :

  1. The NH532 drivers page also has a USB Host Controller driver, while you are using the driver by Microsoft, so you haven't installed all the NH532 drivers.

  2. Your USB device is on the Enhanced Host Controller, which means USB 2. As the NH532 has both USB 2 and USB 3 ports, ensure that you are using the right ports. Your device should be on the Intel(R) USB 3.0 eXtensible Host Controller.

  3. Find in the BIOS (maybe under Advanced / USB Configuration) an entry that may be named something like "Intel xHCI Mode" and ensure it is enabled. Not all BIOS have such an option, but most do.

  4. Go to Intel's Drivers & Software page and use "Automatically update your drivers" to get, install and use the Intel Driver Update Utility. This will get at least, if missing, the Intel(R) USB 3.0 Host Controller Switch Driver.


As according to the poster all the above conditions are correct on his computer, and as the USB 3 device shows up as connected to the Enhanced Host Controller - which serves USB 2, rather than to the Intel(R) USB 3.0 eXtensible Host Controller - which serves USB 3, I am led to the astonishing conclusion of a manufacturing error.

I have no other explanation than that during assembly of this computer, the USB 3 ports were connected by mistake to the USB2 Host Controller, so work at USB 2 speed, or that there is some other problem with the installed ports or controller. If that is the case, there is no software solution to the problem.

  • Thanks for these suggestions, unfortunately I tried them all, but no success. First link only appears to have USB drivers for Windows 7, not 8, do you think I should try those? Apart from that, yes, the laptop has 3 USB 3.0 ports and 1 USB 2.0/eSATA port, I am using the blue ones. There is an entry "USB 3.0 Controller" in my BIOS, set to Enabled. And the Intel update utility only updated the Intel graphics driver. – Groo Jan 5 '17 at 19:15
  • Since the USB3 device appears on the wrong USB Host Controller, is it possible that there was a manufacturing error with your computer - the USB3 ports were connected by mistake to the USB2 Host Controller? – harrymc Jan 5 '17 at 19:30
  • Why don't you contact the manufacturar support? – Scorpion99 Jan 5 '17 at 22:35
  • @harrymc: I opened the laptop today and everything seems to be connected correctly as far as I can tell. There is a actually only a single USB 2.0 port on the opposite side of the laptop anyway, so I believe it would be hard to swap anything accidentally. – Groo Jan 6 '17 at 20:40
  • @Scorpion99: I tried contacting the support through the fujitsu site, but it's rather convoluted and I hoped someone else might have had a similar issue here. I might try again. Honestly, it's not such a young laptop anymore so there is not much support for it anyway. I also tried installing Windows 10 (which is supported) but it didn't help; and finally Windows 10 Anniversary edition isn't supported anymore according to the Fujitsu site. – Groo Jan 6 '17 at 20:42

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.