1

Yesterday I inserted a brand new SSD drive into my laptop and installed Windows 10 Enterprise. Most things work ok, and I am getting used to the new interface (coming from 8.1). However, alt+tab does not work. The only result of pressing the combo is that the current window loses focus.

I tested right after a boot and it works briefly, but then stops having any positive effect after a while. Win+Tab works but the alt+tab shortcut has long ago become muscle memory so I want to keep it. :)

I am thinking that there is some sort of software I installed that caused this since it works for a while after boot. AquaSnap Pro has some keyboard shortcuts but none that go near alt+tab as far as I can tell. Greenshot also has some but should not block it either. I am not currently running AutoHotKey even if I want to once I figure this out.

Is there a way to see what "happens" in the OS when you press a hotkey like this, and figure out which application "eats" the event?

Any other tips on getting my alt tab back?

  • Flagging edits like that is frowned upon. You're allowed to answer your own questions, too! I would delete the two edits and create an answer, instead. Rephrase it as instructions, explaining the methodology you used. – T.J.L. May 6 '16 at 12:42
  • Yes, I will, this was a work in progress and I didn't have an answer as I worked on it, thus the edit to show the current status. – Rune Jacobsen May 6 '16 at 13:10
  • Please don't edit the answer into your question. Super User is a question and answer site and answers should be separate from questions. You can answer your own question instead. – DavidPostill May 6 '16 at 13:10
  • Yes, as I commented to the previous poster to point this out, I didn't have an answer at the time I made the edits. It was a work in progress. I doubt showing what I was trying to do would work as an answer. However, now that I have an answer, I will shortly post and accept an answer to it. – Rune Jacobsen May 6 '16 at 13:13
2

Here is the solution to what was going on;

I use Launchy (2.5/2.6b doesn't matter) with Alt+Esc as the hotkey for activation. This apparently does not make Windows 10 happy. It worked fine with Windows 8, Windows 7, Windows Vista and probably XP before that (long time Launchy user).

If I change the Launchy hotkey to for instance Ctrl+Space or Alt+Space, Alt+Tab keeps working as expected.

I know that Alt+Esc has an action attached to it in Win10, but I did not realize it would react like this to having one of the hotkeys overwritten. So I dunno if this would need to be "fixed" in Win10 or in Launchy - neither is very likely anyway so I better get used to the new key combo.

  • I just discovered this issue with launchy as well. Thanks for mentioning that a hotkey for launchy will fix things so both launchy and alt-tab work. – firedfly Jun 26 '16 at 15:53
1

This is how I got it to work on my computer

  1. Go to start and type "Regedit" and hit enter
  2. Go to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer
  3. Create a new 32-bit DWORD value named AltTabSettings and set it to 1
  4. Reboot your machine

After your computer boots back up Alt+Tab should work

  • Thanks for your suggestion, I will try it if my current attemps (see edit) don't work! – Rune Jacobsen May 6 '16 at 11:58
  • 1
    This solves the problem. Hard to believe I lived with Alt-Tab being broken for a year. – David Chappelle Aug 2 '16 at 2:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.