2

I've got a new PC. I installed Windows 10 and Ubuntu on it.

Now in windows 10, when I log in I get the error message saying:

Unknown USB device (Configuration Descriptor Failed)

Looking in the device manager I get following details on this error:

Windows has stopped this device because it has reported problems. (Code 43) A request for the USB configuration descriptor failed. Location: Port_#0010.Hub_#0003

Question: How to find out the faulty part and resolve the error?

Things I have done so far:

The only USB preferential I have connected are mouse (logitech u0026) and keyboard (logitech k120), and both are working fine. I even disconnected one at a time, restarted, and the same error appears. (I cannot disconnect both because I cannot log in windows anymore).

My MOBO is Asus X99-A/USB 3.1 (see here.) My case has 1 mic jack, 1 headphone jack and two USBs on the front, both work fine. When I stick a usb flash memory in them, they appear in device manager as "USB mass storage", under locations: Port_#00XX.Hub_#0003. I tried to disable those entries in device manager and it did not had any effect in the error.

Thanks

  • Have you tried reinstalling your motherboard's chipset drivers? If not, do so. – AStopher May 7 '16 at 12:26
  • 1
    Actually while installing windows on the blank HDD, it did not ask me for drivers so i never installed mobo drivers. I will try to download and instaill mobo chipset drivers now to see if it resolves this error. – cybergeek654 May 7 '16 at 12:33
  • I downloaded the latest mobo chipset driver from asus website,i tried to install it but got a message that my current installed version is newer than the downloaded one! so i think i will keep it as is. – cybergeek654 May 7 '16 at 12:57
  • You need to uninstall the actual chipset driver and reinstall it. It doesn't matter if the latest on Asus' website is older. – AStopher May 7 '16 at 13:07
  • UPDATE: I turned off the PC, UNPLUGGED the computer, waited several minutes, and now it seems the error has gone! Need to wait more to confirm if the problem will reoccure or not. so far few hours, error-free! – cybergeek654 May 7 '16 at 14:32
-1

You can try running this Intel chipset utility, downloading from the Intel web site from this link.

Intel® Chipset Device Software (INF Update Utility)

  • Welcome to superuser: While this may or may not solve the question, it would be a better answer if you could provide some explanation why your solution works with detail and an easy to follow instructions. If you feel your answer is correct do these things and re-edit. Please take a couple of minutes and read:- superuser.com/help .Answering: superuser.com/help/how-to-answer, again welcome to superuser.Thankyou – mic84 Jun 1 '17 at 11:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.