0

My ISP has given me a real piece of crud fiber-optic modem (an EPON HG220G-U), and I'm trying as much as possible to turn it into a dumb pipe, and have my Mikrotik RouterBoard do all the real work.

This is turning out to be more complicated than I thought, and it's not made easier by the fact that I'm in China, and the modem web interface is all in Chinese. I speak Chinese well, but... not networking Chinese.

I've gotten into the modem's "secret admin interface", and found the router/bridge switch, but no matter how I fool with the settings, I can't log in to the PPPoE account with the Mikrotik.

Once I've set the modem to bridge mode, there are many other settings:

  1. Protocol (leaving at ipv4 for simplicity's sake)
  2. MTU (presumably 1500 is fine)
  3. Vlan on/off (I know theoretically what vlan is, but do not know how it comes into play here)
  4. "service mode" (possibly an incorrect translation). My choices are "internet", "other" and "IPTV". Guess I'm choosing between internet and other.

Then I have "port binding" (another translation guess). I can check as many as I like of four ethernet ports and four wireless SSIDs. I don't know what this means.

If I choose "other" for the service mode, I also get a big table for vlan port binding (pinning?), also four ports and four SSIDs.

I don't know if I'm supposed to be using vlan at all, and I don't know if I should be binding ports. I just want to run a cable between the modem port 1, and the Mikrotik WAN port, and be done with the modem. Currently, no matter how I set things, the PPPoE dialer on the Mikrotik just says "connecting..." and never does.

At present I've bound the Mikrotik's MAC address to 192.168.1.2 in the modem interface, then shut off DHCP and NAT (and wireless) on the modem. Maybe this is actually good enough -- I should already be avoiding double NAT, right?

Any insight into how to handle the service mode and port binding would be much appreciated!

  • You should mention the model of your modem so people can try to get more detailed information. Are you sure the connection is supposed to be PPPoE? – Julie Pelletier May 8 '16 at 4:23
  • @JuliePelletier: You're right! Will add the model. – girzel May 8 '16 at 5:54
0

Bah, as always happens, twenty minutes after I posted this I solved the problem. The modem/router provides multiple "internet connections", each with their own full set of configuration options, which is not something I am familiar with. I could see which connection was actually connected to my ISP, so I deleted all the others. Then I set the remaining connection to bridge mode, left "vlan" checked (still don't know what that does), set the connection type to INTERNET, and bound LAN port 1. After that I was able to dial the PPPoE account from my own router, and connect successfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.