More specs:

  • It works on all other devices in my house.
  • I am missing a connection-specific DNS suffix, and no default gateway. The auto ip is a 169.54.x.x
  • The ip address of the router : IP Address

Tried: -reinstalling drivers - rebooting everything

Let me know what steps I can take, I will be here for immediate response.

  • Why is your router set up with an APIPA address? You should choose an IP from the private ranges and enable DHCP on the router as @lewis4u suggests in his answer. When a device then gets an IP from the 169.254.x.x range it means it was not able to get one from a DHCP server and thus also was not able to get a gateway IP. If your other devices have 169.254.x.x addresses AND a gateway IP then it is probably set up manually.
    – Zina
    May 9, 2016 at 8:58

2 Answers 2


When DHCP fails to automatically assign an IP address, the best thing to do is to assign your IP address manually, both on the router and on your computer.

This is what worked for me on Windows 10:

  1. Set your IP address, default gateway and subnet mask manually in your network adapter settings.

  2. In your router settings, reserve a particular IP address (the same one you used in your network adapter settings) for your Windows 10 computer. In my router, it was found in Address Reservation under the DHCP section.

Once this is done, there should be no confusion about what IP address to assign to your computer.


You need to set your settings like this and modem/router must have DHCP enabled and your devices should connect automatically! network settings

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .