0

I have avahi-daemon running on my BeagleBone Black machine (Debian Jessie). It is in the same network as my PC, but I wonder why when I register service with avahi-publish on my BBB, I cannot see it when i browse services with dns-sd -B on my PC?

Connection between BBB and PC is over (ethernet cable) router and over USB service port.

  • Is this over Wi-Fi? What exact commands are you running on each side? – Spiff May 9 '16 at 15:42
  • Faced a similar problem, published a service, but could not browse it. It happened that my router was blocking my service publishing if i was not using one of http, workstation. It s clearly a specific limitation of my router. But it was not obvious. Maybe you face similar issue. – mh-cbon May 15 '16 at 11:17
0

Is this over Wi-Fi? It's easy for bad Wi-Fi products to break multicast, which mDNS[-SD] relies on. Test pinging the all-hosts multicast address, 224.0.0.1, from each device and make sure all the other devices respond.

If your AP has "client isolation" enabled, disable it.

If your AP has WPA2 "mixed mode" enabled (WPA2+WPA, AES-CCMP+TKIP) switch it to pure WPA2 w/AES-CCMP. Some products don't deal well with having a different multicast cipher than their unicast cipher, and no one really needs TKIP anymore anyway.

Make sure your AP's rate set and multicast rate are set such that all your clients can reliably receive multicasts.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.