0

I have received a Samsung Ativ Book 4 (model no. NP4705E-K01UB [this computer is UEFI compatible BTW]), and for the first few months that I used it, it has worked fine with MBR partitioned disks.

However, recently I installed OS X 10.9.1 as my secondary operating system, Linux being my primary; and naturally I knew that partitioning the disk as GPT would be required. Anyway, that's no problem. So I back up my data and partition my HDD as GPT, 3 partitions altogether, and I successfully install Mavericks. Great.

Unfortunately, when I reboot after the install I get an error message stating that all boot options have been tried and to restart the computer.

Looking in the BIOS I am surprised to see that my hard drive is not only not listed as a bootable drive, but it ISN'T FOUND AT ALL! My BIOS does not see it internally. Doing further tests, I took out the HDD and connected it via external USB 3.0 connection and the hard drive is recognized just fine! So it seems my BIOS refuses to read the GPT disk internally for whatever reason.

Is there anyone who could shed some light unto why this peculiar problem only is relevant when the disk is connected internally and non-existent when connected via USB? Is there a solution to this problem? I have a temporary fix at the moment, having installed a EFI boot-loader called Clover onto a 1GB flash disk; I must use this Flash Drive to boot up into my HDD every time. Rather annoying. Appreciate any of the help I can get!

Here's some pictures of my BIOS:

enter image description here

enter image description here

Boot List: Kingston DataTraveler is the Flashdisk I mentioned earlier:

3
  • Can you mount the EFI partition and post a screenshot of its contents? How you mount the EFI partition in Windows is well documented.
    – Ramhound
    May 11, 2016 at 16:00
  • The only screenshots you have provided are from boot-related pages. Please look for SATA settings and see if it’s listed there.
    – Daniel B
    May 11, 2016 at 16:34
  • I've uploaded a photo of the SATA settings. May 13, 2016 at 5:02

1 Answer 1

2

Are you sure you have setup the Bios to operate as UEFI only ? (Without legacy/CSM support.)
I've seen a couple of Bios variants that wouldn't accept GPT disks for UEFI boot if the legacy support was also on.

The logic seems to be based on the incorrect assumption that if you have legacy enabled your OS isn't UEFI capable and therefore also is MBR boot only. So the Bios doesn't even attempt to boot from the GPT/UEFI harddrive.

Weird thing is that those same Bios often do boot from an GPT/UEFI external media if you manually select that as boot-device. Makes no sense whatsoever...

6
  • Hello, thanks for taking the time to answer! Yes I am sure to have set the BIOS for UEFI OS only, having just checked and confirmed. Also, another interesting thing I noticed, was that my HDD (a Toshiba) is recognized on the first page of the BIOS as the SATA 1 port, however there are no boot options for it still. Would changing the AHCI settings have any effect? May 9, 2016 at 10:05
  • Maybe if it currently isn't set to ahci. (Legacy or ahci/raid could be problematic.)
    – Tonny
    May 9, 2016 at 10:46
  • AHCI was on manual and enabled, and I've switched it to automatic with no noticeable difference. I've tried switching the CSM or UEFI to both ON and this made no noticeable difference either. May 9, 2016 at 12:33
  • Mmmhh.. Very strange. I'm all out of ideas at this point.
    – Tonny
    May 9, 2016 at 12:52
  • So when you boot off a flashdisk, you are actually running the hard drive from the internal laptop SATA port? I don't understand how you are able to boot off the hard drive if your BIOS is not recognizing it.
    – user576053
    May 9, 2016 at 20:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.