1

I'm pulling my hair out with this one.

I've got a HP TouchSmart 320 PC that I upgraded to Windows 10 mid last year from Windows 7. Bought the PC with W7 installed. Have had it in a box for months while I was overseas and turned it on a few days ago to find the keyboard scrambled. Stupidly, rather than buy a new keyboard, I decided to do a reset of Windows 10.

My problem now is a reboot loop with Error: Inaccessible_Boot_Drive. I couldn't access BIOS (it says for my PC to hit ESC, but I've tried that as well as all the F1-12 keys, etc). I've downloaded the Windows 10 iso and have successfully got it onto a usb correctly with my mac using boot camp. Everything goes well as it enters Windows set up when I plug it in but the problem now is that my 4 Disk 0 partitions (System, etc) have this error:

Windows cannot be installed to this disk. the selected disk has an MBR partition table. On EFI system, Windows can only be installed to GPT disks.

I've been reading further into this and it looks like theres some (bad?) suggestions saying to delete these partitions and make my own new ones, but people have also said thats not a wise idea. Other instructions say this:

1. Follow these steps if the hard disk volume size is less than 2.19 TB: Temporarily disable the EFI Boot Sources setting in the BIOS: Restart the computer, and then press F10 to enter the BIOS. Navigate to Storage > Boot Order , and then disable the EFI Boot Sources . Select File > Save Changes > Exit .

2. Install the Windows operating system.

3. Enable the EFI Boot Sources setting in the BIOS: Restart the computer, and then press F10 to enter the BIOS. Navigate to Storage > Boot Order , and then enable the EFI Boot Sources . Select File > Save Changes > Exit . Follow these steps if the hard disk volume size is greater than 2.19 TB: Follow the steps in the Microsoft document titled "How to Configure UEFI/GPT-Based Hard Drive Partitions" (in English) to create a GPT partition

But, I'm back to square one because I can't load the BIOS menu no matter what I press. With the usb in, it just goes to windows set up. Without it, I'm stuck in the boot loop.

I would be so grateful for any suggestions! I can follow instructions but I'm no IT whiz. Also - if its relevant, I only have access to a Mac for now. Thank you!

EDIT: My scrambled keyboard was only affected on the right third (approx). So I don't think thats the problem when I'm trying to enter BIOS as I checked before I reset the computer and ESC, all the F keys, spacebar and most of the letters were ok.

0

Your disk seems to be formatted MBR and the flash drive with the ISO is in GPT format. I have had this issue before. You can use Rufus or similar software to convert the flash drive to MBR boot disk or using a Linux live image reformat the entire disk and set it to GPT.

13
  • Hm ok, I've tried using unetbootin but it didn't work either. I was hoping I wouldn't have to, but t've decided to load windows on to my mac using boot camp and create the usb loader through there either with rufus or windows media creation tool... Hopefully that works! Thanks for your help
    – Dani
    May 10 '16 at 0:46
  • Update - I've got windows successfully running on my mac via boot camp. I tried using rufus, I followed so many different instructions and still couldn't get it to work. I ended up getting the windows 10 media creation tool and have used it to download windows again, and I'm still faced with the same error, and I still can't get into BIOS or the other UEFI thing... Have you got any more suggestions? I feel like I've actually tried everything possible now, including using different types and brands of USBs.
    – Dani
    May 10 '16 at 5:31
  • As I get from your question your HDD is MBR formatted and your disk is GPT. In Rufus, in the top dropdown select Master Boot Record format (other is GPT for EFI) and then select the ISO and reformat. I can update the answer with detailed steps and screenshot if you wish.
    – Roh_mish
    May 10 '16 at 6:38
  • Also if your drive is not soldered and can be removed and you have the SATA-USB converter, try using that
    – Roh_mish
    May 10 '16 at 6:39
  • Alright I'll give rufus another go. I've just bought a new keyboard too so I can actually enter BIOS or something now if need be. Could you please help me with which options to select for rufus? Do I need: "MBR partition for BIOS or UEFI-CSM", or "MBR partition scheme for UEFI"? Also, should the file system be NFTS/Fat32/UDF/exFAT?
    – Dani
    May 10 '16 at 7:26
0

Thank you @Roh-mish for all your help. I finally figured this out, and as I haven't seen the answer anywhere else online I'll share in case this happens to someone else. After getting stuck on the black screen with the "an OD wasn't found" error, I went back in to BIOS after restarting, and navigated to Storage > Boot Order. Here, under the Legacy settings > Hard drive, I had to reorder the boot sequence so that my USB device was first, and the SATAO was second. I also reordered the options under UEFI Boot Sources so that USB Hard Drive was 1st, then CD/DVD, then USB floppy.
After that I was able to get back in to the installation process and successfully install Windows 10 on Partition 3 (the 1TB OS partition).

1
  • Good that your problem got solved. Anyway, good luck with new installation.
    – Roh_mish
    May 10 '16 at 8:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.