0

1) Need to configure unattend.xml file to do not ask to enter the windows product key in the post-sysprep boot. And leave the product key blank.

The only way I found to do this is by configuring unattended xml file - 7 oobeSystem - microsoft-windows-shell-setup_neutral - OOBE - SkipMachineOOBE to "true"

But WSIM online help states very clearly that this is an obsolete option that shouldn't be used on production with windows 10 as it will conflict with other options.

2) Also need the post-sysprep boot to ask for the hostname in this format: PC1234 PC is a constant, and it would be great to hardcode it, and only need to enter the numbers. This I have little clue on how to do it with an unattended .xml file. Is there an unattended option for this I'm missing?

  • I want to make sure I understand what you want. You want the unattend.xml, to handle inputing the product key, is that correct? – Ramhound May 9 '16 at 20:16
  • Want the unattend .xml file to command the sysprep process to skip/omit etc. the product key. That will be taken care later. I need to not enter a product key in sysprep. – amm May 9 '16 at 20:27
  • want to skip this screen [jpg link ->] zdnet1.cbsistatic.com/hub/i/r/2015/10/13/… – amm May 9 '16 at 20:36
  • It seems straight forward. Product Key Prompt - Unattended Install, ProductKey, and Key – Ramhound May 9 '16 at 20:49
  • Don't know what you took as an agression, I just wanted to be clear, not only for you but for anybody. 1) I need to not enter the product key -and- 2) not specify product key on the .xml file; product key must remain empty, so the links you provided aren't useful in this case. – amm May 10 '16 at 13:49
0
  1. I got same issue recently and it's my WORKING solution:
<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
    <settings pass="windowsPE">
        <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <SetupUILanguage>
                <UILanguage>en-US</UILanguage>
            </SetupUILanguage>
            <InputLocale>0c09:00000409</InputLocale>
            <SystemLocale>en-US</SystemLocale>
            <UILanguage>en-US</UILanguage>
            <UILanguageFallback>en-US</UILanguageFallback>
            <UserLocale>en-US</UserLocale>
        </component>
        <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <UserData>
               <AcceptEula>true</AcceptEula>
               <FullName></FullName>
               <Organization></Organization>
               <ProductKey>
                  <Key></Key>
                  <WillShowUI>Never</WillShowUI>
               </ProductKey>
            </UserData>
            <DynamicUpdate>
               <Enable>false</Enable>
               <WillShowUI>Never</WillShowUI>
            </DynamicUpdate>
            <EnableFirewall>false</EnableFirewall>
            <LogPath>C:\Log</LogPath>
        </component>
    </settings>
    <settings pass="offlineServicing">
        <component name="Microsoft-Windows-LUA-Settings" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <EnableLUA>false</EnableLUA>
        </component>
    </settings>
    <settings pass="generalize">
        <component name="Microsoft-Windows-Security-SPP" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <SkipRearm>1</SkipRearm>
        </component>
    </settings>
    <settings pass="specialize">
        <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <InputLocale>0409:00000409</InputLocale>
            <SystemLocale>en-US</SystemLocale>
            <UILanguage>en-US</UILanguage>
            <UILanguageFallback>en-US</UILanguageFallback>
            <UserLocale>en-US</UserLocale>
        </component>
        <component name="Microsoft-Windows-Security-SPP-UX" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <SkipAutoActivation>true</SkipAutoActivation>
        </component>
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <ComputerName>PC_NAME</ComputerName>
        </component>
    </settings>
    <settings pass="oobeSystem">
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <UserAccounts>
                <AdministratorPassword>
                    <Value>PasswordHERE</Value>
                    <PlainText>true</PlainText>
                </AdministratorPassword>
            </UserAccounts>
            <AutoLogon>
                <Password>
                    <Value>PasswordHERE/Value>
                    <PlainText>true</PlainText>
                </Password>
                <Username>Administrator</Username>
                <LogonCount>99</LogonCount>
                <Enabled>true</Enabled>
            </AutoLogon>
            <OOBE>
                <HideEULAPage>true</HideEULAPage>
                <HideLocalAccountScreen>true</HideLocalAccountScreen>
                <HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>
                <HideOnlineAccountScreens>true</HideOnlineAccountScreens>
                <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
                <NetworkLocation>Work</NetworkLocation>
                <ProtectYourPC>3</ProtectYourPC>
                <SkipMachineOOBE>true</SkipMachineOOBE>
                <SkipUserOOBE>true</SkipUserOOBE>
            </OOBE>
            <TimeZone>Central European Standard Time</TimeZone>
        </component>
    </settings>
    <cpi:offlineImage cpi:source="" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>
  1. I handle it differently while creation of VM. I just replace hostname in Powershell script - here PC_NAME - with expected value(given as parameter) and thats it.

    I hope that helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.