7

I read that I could re-enable NPAPI in Chrome after Google decided to stop supporting these plugins (I suppose in order to force developers to embrace WebGL solutions) but the flag doesnt show up in the most recent version of Chrome (50.0.2661.94 m).

Is it no longer possible enable NPAPI on Chrome?

1
  • 1
    Removed in September of 2015. According to this article that was listed as an answer while I was typing and talking. May 10 '16 at 8:14
8

The NPAPI architecture doesn't exist in Chrome since version 45.

Webs based on Java applets or Silverlight won't work on Chrome 45 or newer.

4

Unfortunately for plugin users it was always planned to be fully removed eventually. According to this document it was to be totally removed in Chrome 45: http://www.chromium.org/developers/npapi-deprecation

1

Only solution I have found to get around using NPAPI applications in chrome is by using the plugin "IE Tab" but even then they not work properly. Hopefully you find this useful.

If you decide to use IE Tab you may want to adjust the version of IE inside IE Tabs options that you want it to replicate inside of chrome. I found this useful when trying to run certain applications.

Hopefully you find this useful.

1

I had the same issue...tried opening a Skype for Business link for a meeting and couldn't. I tried the NPAPI route and no joy. What worked for me though was downloading Chrome NPAPI Replacement (https://chrome.google.com/webstore/detail/chrome-npapi-replacement/okoafaojkokbmieeefnflkiklhanpeoc?hl=en).

I downloaded it and got into the meeting via Chrome (NOT in Incognito Mode). Hopefully, it works for your needs too.

Good luck!

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.