15

Let me explain in a step by step fashion:

  1. Open chrome (Left screen), start browsing etc.
  2. Open a new tab in chrome and drag it to my Right screen with, let's say, youtube with some music
  3. Click on a link in an external application (skype, irc, slack, usually a chat app), the link opens on the window on the right screen instead of my main one, the left one

I'm really looking forward a solution, so far I couldn't find anything beside opening first the "media reproduction" tab and second the "main work" tab (which is definitely counter-intuitie).

Are there any solution to this behavior?

9
  • As far as I know, the link will be opened in the last used chrome window. So after you move the second chrome window on your right screen, switch to the chrome window on the left screen and go back to work. This has nothing to do with chrome, it is the OS and the window Z-order of active apps.
    – Zina
    Commented May 10, 2016 at 13:13
  • I thught the same, but after a few tries, it still opens only on the second window. Wonder if some app is interfering in some way. Commented May 10, 2016 at 16:39
  • Strange. Maybe you could try to close all chrome windows (check if all processes are gone) and then open two new chrome windows and leave them on the same monitor and see what will happen when you open a link with the first and then the second window selected before you open the link. For me when I open a link it will always open in the last selected.
    – Zina
    Commented May 10, 2016 at 17:47
  • Mh ok, I will also try to reboot since it's like two weeks since I last shutdown the computer, some app may not be "that used" to stay on Commented May 10, 2016 at 18:01
  • 1
    I can confirm @Zina, across one display it works in the way you described, but across two screens, chrome picks only the second window. Basically makes Chrome unusable on two screens at same time, that's so disappointing. Commented May 11, 2016 at 21:02

2 Answers 2

6

The same problem happened to me where the link did not open on the last used window.

Solution - Restart the Chrome app and the links should open as expected. This is what worked for me.

2
  • 4
    Not sure why this got down-voted, because it was the only solution that worked for me as well. I actually completely quit both Chrome and my other app to get links working properly again.
    – Attila
    Commented Oct 22, 2019 at 17:43
  • This answer is probably down voted (I really disagree with down votes without explanation) because it is not really describing a solution properly. We are talking about Chrome with two windows on two monitors. There are multiple "restart Chrome" scenarios to take you back to that position. And also this is happening to us every time we start Chrome anyway, so it needs to be really specific what you mean. Just take a look at your "answer" and consider it's only 2 lines. Try and read it from the point of view of someone who isn't you and can't read your mind.
    – NeilG
    Commented Jul 10, 2023 at 3:43
1

Empirically, it seems that if you pass --app=my-url --disable-infobars when starting your Chrome window, it will prevent links from external apps from opening on that window. A downside (or upside) is that the window won't have a URL bar or tab bar so you won't be able to open more tabs on that window.

For example:

google-chrome --app=https://www.youtube.com --disable-infobars

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .