17

I'm using the Remote Desktop Connection Manager 2.7 on a Surface Pro 4 with Windows 10. Until recently, it was working fine: It would go to full screen and show this blue full screen connection bar at the top when pointing there with the mouse. I could close the session from there or leave full screen mode.

A few days ago (no idea what happened), it stopped going to full screen properly. Now it only resizes to the full size of my screen minus the task bar (so I still see that and the RDCman's window is also not behind my local task bar. The blue bar at the top appears for a moment but I cannot get it back when moving the mouse there.

Reinstalling did not help. Any idea what might have caused this and how to fix it?

26

Simpler - just don't maximize the Remote Desktop Connection Manager window.

I just resize the RDCMan window to "almost" maximum size, then hit Full Screen in the RemoteDesktop connection (right click-> Full Screen).

Otherwise, it seems Windows 10 keeps a bottom bar reserved for the taskbar & doesn't allow the remote desktop to go "all the way" Fullscreen.

  • 6
    This did the trick, thanks! Really nonsense behavior of Windows... – Niko Jun 29 '16 at 20:50
  • I don't want to +1 this, but this has been nagging at me for 3 years of using a High DPI and this totally worked. Bookmarking this! – WhiskerBiscuit Aug 2 '16 at 20:52
  • +1 for this solution, simple and easiest to full screen with high DPI device, no need to play with registry hack, however, is there any way to hide the remote desktop connection bar in Remote Desktop Connection Manager? – Bilo Aug 3 '16 at 1:44
  • 3
    Wow. Didn't understand what you meant at first. Basically if your RDCMan is maximized, your screwed and it won't hide your status bar. If you have it not maximized, full screen works as expected. Weird. – Unome Oct 27 '16 at 22:15
  • This also fixes the issue with key combinations (like Alt+Tab/Windows key) not being forwarded to the remote you are connecting to. Super strange behavior... – mrexodia Oct 8 '18 at 10:30
2

I know this is an old post but I had a similar problem and found that this worked:

  1. Find rcdman.exe.
    Default location: C:\Program Files (x86)\Microsoft\Remote Desktop Connection Manager\RDCMan.exe
  2. Open the Properties of the exe (Right click -> Properties)
  3. Go to the Compatibility tab
  4. Uncheck Disable display scaling on high DPI settings
0

Click View, then un-check Lock window size.

  • Thanks, but it was already unchecked. – Niko May 10 '16 at 18:11
  • Is the remote desktop size still set to Full screen? Either at this specific connection entry, or the parent folder, or however you have it setup. – Steve Freeman May 10 '16 at 18:24
  • Yes, and the size of the remote desktop is also the size of my local screen (I just get scrollbars instead of expanding properly over the task bar). – Niko May 10 '16 at 18:55
0

This worked for me http://answers.microsoft.com/en-us/surface/forum/surfpro4-surfnetwork/surface-pro-4-windows-10-remote-desktop-other/d17d4321-0f04-4a64-95b4-1c6dd5de9c91?page=1

Here is what I did to solve the issue.  It also works with older apps that don't handle high dpi scaling well. First one must tell Windows to look for a manifest file for an application by default – a registry entry. Next is to provide a manifest file for a given application – the executable file name followed by .manifest.

  1. Open RegEdit and navigate to the registry key: HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > Windows > CurrentVersion > SideBySide.
  2. Right-click, select NEW > DWORD (32 bit) value.
  3. Type PreferExternalManifest, and then press ENTER.
  4. Right-click PreferExternalManifest, and then click Modify.
  5. Enter Value Data 1 and select Decimal.
  6. Click OK. Exit Registry Editor.
  7. The RDP app is %windir%\System32\mstsc.exe so the manifest file is mstsc.exe.manifest.

I can't attach the manifest file so here is the contents:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0" xmlns:asmv3="urn:schemas-microsoft-com:asm.v3">
    <dependency>
        <dependentAssembly>
            <assemblyIdentity 
                type="win32"
                name="Microsoft.Windows.Common-Controls"
                version="6.0.0.0" processorArchitecture="*"
                publicKeyToken="6595b64144ccf1df"
                language="*">
            </assemblyIdentity>
        </dependentAssembly>
    </dependency>
    <dependency>
        <dependentAssembly>
            <assemblyIdentity
                type="win32"
                name="Microsoft.VC90.CRT"
                version="9.0.21022.8"
                processorArchitecture="amd64"
                publicKeyToken="1fc8b3b9a1e18e3b">
            </assemblyIdentity>
        </dependentAssembly>
    </dependency>
    <trustInfo xmlns="urn:schemas-microsoft-com:asm.v3">
        <security>
            <requestedPrivileges>
                <requestedExecutionLevel
                    level="asInvoker"
                    uiAccess="false"/>
                </requestedPrivileges>
        </security>
    </trustInfo>
    <asmv3:application>
        <asmv3:windowsSettings xmlns="http://schemas.microsoft.com/SMI/2005/WindowsSettings">
           <ms_windowsSettings:dpiAware xmlns:ms_windowsSettings="http://schemas.microsoft.com/SMI/2005/WindowsSettings">
            false
            </ms_windowsSettings:dpiAware>
        </asmv3:windowsSettings>
    </asmv3:application>
</assembly>

Copy the above into notepad and save the file with the appropriate name to the same folder as the executable.

  • This is the solution to a different problem... – Niko May 10 '16 at 20:15
  • Thought it would help. Do you have to use RDCMan? Royal TS is a pretty good application. – E.V.I.L. May 10 '16 at 20:21
0

Right-click the host, properties>display settings: uncheck inherit from parent and check scale docked remote desktop to fit window

On v2.7 build 1406.0, not sure if this was released in an update, just wanted to point it out in case people are still searching.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.