When I'm restarting my PC I have no instructions on how to get to BIOS. I mean no key combination for that or something. At all. I restarted my PC many times and wasn't able to see something about that.

I tried basically all the Fn (F2, F12, F3, F1 etc.) keys. I also tried Del, Esc and even more. Don't even remember all this keys and combinations I've tried while trying get into BIOS.

My Motherboard is MSI PH61A-P35 (MS-7732). I've read the manual for this keyboard which suggested using the Del key. But as I've alredy said it doesn't work for me. All it does is restart my computer.

My computer is running Windows 7.

How can I get into BIOS?

  • 1
    Try powering it off, then hold the power button to turn it on. If it beeps while holding it, let go and hopefully that'll throw it into the BIOS. May 10, 2016 at 19:58
  • 2
    What operating system are you running? Update your question to include this information.
    – Ramhound
    May 10, 2016 at 20:10
  • 5
    @Ramhound why would knowing the OS help in this instance? He is trying to get into the BIOS.
    – Burgi
    May 10, 2016 at 20:16
  • 1
    @Burgi - I wanted to ask the same question - What OS are you using? For me this is because I know certain windows fastboot systems do not give access to the BIOS, requiring you to reset the BIOS manually to access them.
    – Matthew
    May 10, 2016 at 20:48
  • @Burgi I'm using Windows 7 for this task.
    – 9Algorithm
    May 10, 2016 at 20:50

13 Answers 13


Thanks for the answers! I'm sure these answers will be helpful for somebody facing this problem. But it all didn't work for me.

I solved this problem by switching my current USB keybord to my old PS/2 keybord. After that I was able to enter BIOS with the F2 key. The problem with USB keybords is they are not recognized by the computer until the OS starts to load. So switching to a PS/2 keybord will do the trick.

  • 1
    Same problem here. I was lucky I had the old keyboard.
    – pagep
    Jan 5, 2017 at 16:58
  • Thanks that saved my issue!
    – Steven
    Jan 14, 2021 at 16:48
  • 3
    What can I do if I don't have an old PS/2 keyboard at hand? I'm desperately stuck...
    – Rotareti
    Nov 12, 2021 at 11:27

Go into windows, and shift+click the restart button, then choose to change the UEFI settings when you get the option to do so.

You can also start the laptop and quickly release and then press and hold the power button. After this press dell rapidly when starting the PC again.

Windows 10 has a fast boot option which makes going into the BIOS more of an issue.

  • I believe that (Shift)+(Restart) works only in Windows 8 and above.  This question is about Windows 7. Jun 24, 2017 at 6:10
  • 1
    this worked for me in win10, which is probably more relevant now that win7 is no longer supported
    – Kairan
    Mar 13, 2020 at 18:07
  • I would like to add that rapidly pressing the required keys is not necessary. You can also just hold down the desired keys to get the same effect. Seeing people spamming keys to get into a BIOS right now seems silly to me :)
    – Maarten
    Jun 11, 2020 at 12:57
  • Works for win10. For others, will point out that you have to dig down into advanced options. When you pick UEFI setting, it'll simply reboot to BIOS.
    – Mastiff
    Jun 19, 2021 at 15:13

Here's an old hat trick that just might work for you, and others in similar situations. I don't know if this will work on your specific motherboard.

Turn off the computer. Then, before turning it on, press and hold a key on your keyboard. (Any key will do. Control, Windows, Print Screen and such are usually "safer" in light of any firmware on extension cards etc.) Now, while holding that key down, turn on the computer. Do not release the key before the OS starts to load, if it does. (If the OS starts to load, this trick didn't work for you.)

What this does is basically cause the BIOS to see a "stuck key" condition on the keyboard; the same as if a keyboard contact was actually stuck, but in this case, triggered intentionally. Many BIOSes treat this as at least a warning, and will give you a diagnostic screen telling you to check your keyboard and do something (most often to press a key) to continue booting. This diagnostic screen very often includes instructions on how to enter the setup utility as well and now that the BIOS is actually waiting for you to do something, it's often a trivial matter to get into the setup utility.

  • This method does not work for me - Windows 7, Toshiba Satellite
    – Matthew
    May 10, 2016 at 22:21

remove any hard drives ata cables at motherboard, reboot and F2 (usually on laptops) or del on other computers, some are F10 or Esc change uefi boot to cms startup and remove secure boot after this you an even change boot sequence

other method is to go to parameters/updates/restart now and then advanced and then micro logiciel (in french) , something like this

  • That was very clever! After disconnecting the booting drive I was able to enter the BIOS. Thank you! Oct 15, 2017 at 18:18

For me, the reason for this was that I had MSI Fast Boot on. It disables USB communication to speed up the boot process to Windows. That could explain why older PS/2 keyboard works.

MSI has a tool called Fast Boot that one runs from within Windows and from there one can choose to disable Fast Boot or to restart and boot into BIOS automatically.

I found the tool by googling for my motherboards name, visiting it's site, going to the download section if it doesn't take you there automatically then go to Utility section.


If fast boot is the problem, an easy way to disable it is to leave windows in an unsafe exit state, which you can do by a hard shut down (holding the power button for several seconds)


Make sure not to have keyboard plugged into USB 3.0. In other words if the usb slot is blue switch to a black one.

  • i read this comment as "use the USB 3.0 port" and plugging the keyboard into the USB 3.0 port was the solution in my case
    – hypothesis
    Oct 16, 2019 at 8:23

I have the same problem, after searching a lot from forum, website and Youtube. Maybe this step will work for you to.

My PC using MSI motherboard.

  1. Unplug Power (or switch off will do)
  2. Remove cmos battery
  3. Press on button for 30 second
  4. Put the cmos battery back to it place
  5. make sure your keyboard & mouse at the black USB slot
  6. switch on the pc
  7. Hold F2 while press start button
  8. The screen will show you that the setting has been reset to standard.

It will ask you to press F1 to resetting your confirguration or F2 to continue load the windows.

Thank you


Certain Windows Fastboot systems do not give access to the BIOS, requiring you to reset the BIOS manually to access them.

If you need to reset the BIOS manually, you can do this by removing the battery from the motherboard or physically branching the CMOS reset connectors on the motherboard.

Instructions: Turn off and disconnect your computer from current. Make sure you and the computer are grounded and protected from static, as static can be very damaging, even fatal, to your delicate components. Open the case and identify the CMOS battery – it is like a big hearing-aid battery. Carefully remove the battery. Now hold down the power button to drain any residual power from the motherboard. Re-attach the battery and now reboot the computer pressing Delete key or F8 or F2 (etc.) keys to reach the BIOS.

If this does not work you can branch the the CMOS reset connectors on the motherboard. Consult your motherboard manual to find these connectors.

Once you have accessed your BIOS and made any necessary changes, you can choose to reinitiate the Fastboot if you want. I do not use Fastboot on my own PCs but activate it on the PCs I build for my clients.


i had the same bios problem like you and solved it by download the Live Update 6 from MSI. Then inside it click to scan for the ClickBios. After complete installing, you can access your BIOS from the app ClickBios in Windows. Then restore bios to default setting will make bios screen appear again. The error for this i think cause by fast boot from msi.


If your motherboard has the fast boot app use that to go to bios, then go to boot settings and disable OS fast boot and enable MSI fast boot...it worked on my pc.. i have Z370 krait gaming MOBO.

  • 1
    Except for the fact that this does not apply to Windows 7, this is a somewhat valid answer. When fast boot is enabled, you cannot enter the firmware setup by pressing a key. Instead, you’d use Advanced Reboot or its cross-OS equivalents.
    – Daniel B
    Dec 2, 2018 at 12:20
  • @Dave M That's a workaround through OS, after you manage to do that you have direct access to the bios because you bypass the press key phase...
    – Kyo
    Dec 2, 2018 at 16:53
  • @DanielB since it's specifically about MSI MOBO it might have a tool from MSI but i cannot say something more cause it's been a long time since i used Windows 7.
    – Kyo
    Dec 2, 2018 at 17:07

I had this exact same problem. It was very frustrating, the solution now I know the answer is fairly straight forward, if you refer to your manual you will see for the bios to function via keyboard and mouse only specific usb ports will work. In the case of my MSI X370 it was the top left for the keyboard and 3rd row right for the mouse. Pressing "Delete" on the keyboard on start up will enter Bios mode.


Recently I discovered that I had the can't get into BIOS problem with my MSI X58M based i7 computer. I tried connecting the keyboard to all the USB ports and even tried a PS/2 keyboard w/o success. Then while shutting down, at "Power" I chose "Restart" rather than "Shut down", or "Sleep". When the splash screen saying hit DEL to enter BIOS came up I hit DEL and WA-LA! I got BIOS. This has worked every time I have tried it on this MB. Just to verify, I went back and selected "Shut down" instead of "Restart". Upon starting, hitting DEL did nothing and Windows started. It seems flakey, and probably will not work in all or even most cases, but it just might work for you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .