2

I am trying to rescue the data off a failing external hard disk, but I am running into a number of problems.

The file transfer will consistently freeze up on specific files, and the program being used to transfer the files enters the "not responding" phase, and the program turns white. When attempting to end the task of the frozen program, Task Manager doesn't throw any errors (such as "access denied"), but the program remains in the task list. This has been tried with multiple copy programs, including Windows copy, TeraCopy, Free File Sync, and Roadkil Unstoppable Copier. The queue length of the hard disk in Resource Manager is stuck at 1, however no disk activity occurs.

However, the moment the failing hard disk is unplugged from the system, the unresponsive programs then begin to respond again, and any tasks stuck in the Task Manager immediately end.

What is happening here, and is there a way to rescue the data from the failing drive?

If it matters, I am copying files off the USB3 ports of an Intel NUC5i3RYH, from a WD 1TB My Passport Essential to a WD 3TB My Passport Ultra.

5
2

From your description, it seems obvious that your hard drive is either defective or its content is corrupted. Corruption on a partition can yield many unexpected results, especially when data is corrupted in inodes which tell the OS where the file data is located.

In this situation, you may try running data recovery tools, but copy operations will certainly fail, as you noticed. Data recovery is a very complex matter on its own with absolutely no guarantees.

You should normally start by trying a full image copy of the disk, which would overcome previously mentioned inode problems to avoid worsening the situation. A defective drive usually gets worse as it is being used, which is why you'd want to work on a copy of it.

Once that is done, you should look for data recovery tools to extract as many files as it can from the disk image.

Finally, when you've extracted everything you can get from it, you should try to format it to see if it was simply corrupted or defective. If the formatting goes well, it was probably just corrupted, which is more common with removable drives.

1
  • Attempting to full disk image the drive resulted in failures, with the hard disk throwing "semaphore timeout" errors. I guess the hard disk is pretty much gone, and I will need to restore from backups. – March Ho May 11 '16 at 7:34
2

Boot up a Linux distro and use Gnu DDRescue to attempt to bit-copy the drive to your Passport Ultra. If and when it fails, attempt run it again in the reverse direction. (The idea being to reconstruct as much of the data as you can).

If the copy works OK, the issue is probably a filesystem corruption (but this is unlikely). If not, its most likely a disk issue. [ DDRescue will probably give you hints here as well, if its a filesystem corruption it should copy without errors. If it cant read bits its hardware.

Try and make a copy of the copy you have made, check the filesystem and pull off as much data as possible. If you don't have luck with reading the filesystem, use Photorec to try and recover whatever you can by bypassing the disk structure and looking at the raw data and sigs.

0

I had a kind of a similar issue three years back with my external HDD. The hard disk had a warranty, so I did not need to bother too much about the monetary cost. I had one and only concern about the data which I had in the hard disk which was meant for backing up the internal hard drive of the laptop. After a little bit of research (or say, after a few Google searches), I got to know that there could be two possible reasons.

  1. Corrupted file system in the hard drive: this may take place due to improper partitioning of the hard drive or bad formatting. You may refer to davidgo's answer as I find that good enough.

  2. Physical damage to the platters: or the arm with which the head has been connected does not move correctly as required.

When I was stuck in the issue, I found a way to recover my data: Recuva. It's a freeware product that worked as expected but took 5 hours to complete.

3
  • Recuva cannot reliably be used if the drive is failing, it will encounter the same I/O errors. It is a good solution for deleted files, to be used on a working file system in a working drive. – Andrea Lazzarotto May 13 '16 at 16:46
  • Yes its a good solution for deleted files I admit....give me some time so that I may come out with a more apt solution that may suffice the current requirement – Aniruddha Sinha May 13 '16 at 18:33
  • I gave a possible one in this other question: softwarerecs.stackexchange.com/a/31377/19806 :-) – Andrea Lazzarotto May 13 '16 at 21:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.