3

Few days ago I noticed iTunes skipping through songs. I didn't really understand what was happening so I started investigating:

  • Different networks make no difference
    • no problem with my router / network
  • Different devices make no difference (OS X, iOS, tvOS)
    • no problem with my local installation / operating system / device
  • Happens to songs from "For You", "New" and my library.
    • no problem with my iCloud Music Library or my local library
  • Subscription paid and active (approved by iTunes Store support)
    • no problem with the subscription itself
  • No problem with paid songs from iTunes Store
    • ...but I can't just buy my whole library from iTunes
  • No problem with songs that I stored offline
    • ...but I can't just download every single song I ever want to listen to
  • No problem with radios (e.g. Beats 1, thematic radios such as "On The Dancefloor", custom radios such as "[interpreter] Radio" and "[song] Radio")
    • ...but I can't just start a radio for every single song I ever want to listen to

I opened a case with the iTunes Store Support and still waiting for a response (they told me I might have to wait for up to one week). So if they can resolve it I'll gladly share the solution with others that might have run into the same issue.

Did anyone ever experience the same issue and was able to fix it (using Apple Support or not)?

Does anyone know a way to trigger some routines to maybe delete some kind of cache on your account, that might resolve the issue?

  • 2
    Ive read in few cases of changing your DNS. I read it in one community that countries in the UK as well as a few other countries had issues. They claimed that changing the DNS to Norton's DNS 199.85.126.10 and the issue stopped right away. – NetworkKingPin May 11 '16 at 8:51
  • 1
    You also said something about the cache you can try that here /Library/Caches/com.apple.itunes just delete the folder and relaunch and it will rebuild what it needs. – NetworkKingPin May 11 '16 at 8:55
  • @NetworkKingPin Changing the DNS didn't work (and wouldn't be a solution since I can't change the DNS via mobile network and the issue occurs there as well). I thought about cache on the Apple Servers because my problem is definitely not local as it "follows" me on other devices such as my iPhone and iPad as well. – Fabio Poloni May 11 '16 at 9:01
12

I think you computer is not authorize.

Go to:

Account --> Authorization --> Authorize this Computer

I solve this problem like this!

Good luck!

  • @VladHolubiev You're welcome !! – Cesar Rodriguez Aug 4 '17 at 1:58
  • Thank you so much! Though it said that my computer was already authorized but this magically fixed everything! (I recently updated my mac OS though - a regular security update for HighSierra - so may be this did something). This solution is really valuable :) – Mohit Singh Dec 7 '17 at 8:32
  • This worked. Although it said it was already authorized, it stopped skipping after that. – Steve Dec 11 '17 at 14:58
0

I've had a similar problem in the past where it was due to me making changing to my library on disk, and the cache was still looking for the old song.

PLEASE NOTE: I never used the iTunes Cloud: Only used local files on disk. If you're having issues with cloud files, I'm afraid I have no experience with this.

It would somehow end up in a loop sometimes, which might be a mixture of bad code + me not updating the library.

The solution for me was:

Remove the monitored folder.
Remove library (but not the files on disk).
Re-add the monitored folder and let iTunes re-import the files.

iTunes has a really hard time with managing changed files in my experience.

I don't really use iTunes anymore for reasons like that, but I hope this helps.

  • That wouldn't explain why songs from "For You" or "New" that I haven't added to my library are skipping as well on all my devices (including iPhone and iPad). – Fabio Poloni May 11 '16 at 8:49
  • @FabioPoloni Hence the note because I've never used the cloud on iTunes. The behaviour your describing is exactly what I experienced, but everything was local. Its possible the local problems are having a knock-on effect. Check out the log file discussions.apple.com/thread/1848959?tstart=0 from when it last happened. Might have some clear reasons on why this is happening . – Dandy May 11 '16 at 8:51
  • Ah, you edited your post and I posted the comment in the same few seconds. I'll have a look at the log file, even though I expect it's broken on the Apple Servers. – Fabio Poloni May 11 '16 at 8:58
0

My account suddenly started working again this morning. I was pretty sure the guys from the tech support did some reset but they told me they haven't even started investigating due to a missing approval by myself.

I'll just accept this answer and leave the question here until it happens again and for documentation of the issue that magically resolved itself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.