3

Many websites, including SuperUser, recommend restarting the Windows Update service in order to fix the common problem of Windows Update getting stuck at 0% downloading.

When I try to stop the Windows Update service (via services.msc), Windows 7 SP1 attempts to stop it, but then after waiting a few minutes, reports that it cannot stop the process.

How can I stop the Windows Update process so I can restart it?

  • Are you running as admin? I have no problems stopping it on Windows 7 64 bit (I have it disabled). – DavidPostill May 11 '16 at 19:42
  • If you perform this action after booting to a minimal boot configure does this behavior exhibit itself? – Ramhound May 11 '16 at 19:42
  • @DavidPostill I don't normally run as admin, but for this task, I am. – RockPaperLz- Mask it or Casket May 11 '16 at 19:44
  • @Ramhound I haven't tried that yet, but except for security tools (which I prefer not to disable), there is nothing that runs on bootup. – RockPaperLz- Mask it or Casket May 11 '16 at 19:48
  • @RockPaperLizard - When you decide you want to try my suggestion, feel free to ping me, my suggest involves only booting what is require for the system to fucntion and security software isn't required. Once you determine one way or another feel free to enable everything again. – Ramhound May 11 '16 at 19:54
4

When you attempt to stop a service but after a while it reports back with an error and either it is stopped and doesn't start anymore, or it is still running and you just can't stop it, then the software of the service crashed and Windows is unable to stop it normally.

What I mean with software part of the service is the following. Like a driver for your computer, a service is just a program that runs on your computer. When a program is installed as a service, it runs invisibly and it can be configured to automatically start when Windows starts. To interact with the service, you have to go to the services tab and you can start/stop the program there, or disable it.

When you choose to stop a service, the service program is interacted with, sending a request to stop it. This allows the service program to stop normally, executing some pre-shutdown commands, and then terminate.

Now, if you attempt to stop the service, but the service is not responding, it is waiting for the service to shutdown. Normally, when a service does not respond, it is automatically stopped by Windows. But there is the rare chance, that the service is running, but for some unknown reason, the shutdown command is queued and its waiting for another task to complete first. If this is the case, the service could have crashed.

If you use software like Process Hacker, you can manually terminate the process that is responsible for the service and refreshing the services list should now list the service as stopped and it can be started normally again.

If you don't want to use additional software, simply reboot the computer, and after a complete reboot, the first thing you want to do is stop that service, though rebooting may fix the issue you are trying to solve in the first place.

| improve this answer | |
  • ( starting your profile in a minimal configuration helps in this regard ) – Ramhound May 11 '16 at 22:31
7

The service can get stuck in an interim state - in that case look up the process ID (PID) - it is shown in the service listing - and use the following whilst running the command line as administrator:

taskkill /f /pid [PID]

This worked for me after attempting several other methods.

I now am able to run updates.

| improve this answer | |
  • This worked for me in an Admin Command Prompt. I got the PID using the free application "Process Hacker". Thanks ! – FMaz008 May 15 '17 at 19:58
  • Thanks, worked great for me! Windows wouldn't stop from net stop wuauserv or services.msc, but this fixed it. – Benno Jun 18 '18 at 0:19
  • You can get the PID from the Windows Task Manager on the Services page in the PID column. You should get SUCCESS: The process with PID 1156 has been terminated. immediately, and the PID should disappear from the Task Manager | Services | PID. Note, however, that it will probably start up again automatically in a few minutes, but with a new PID. – FreeText Mar 17 at 18:55
1

Stopping through a cmd prompt running as admin does indeed stop the service. You don't need to be logged in as admin; just be sure the cmd window has admin privileges & you run it as admin. Note: as of 5-17-17, Windows defender will no longer get virus updates unless this service is started. I disabled the update service because Windows would update drivers & certain devices would no longer work. Bad Windows!

| improve this answer | |
0

Open an Administrator Command Prompt. Type the following to stop the windows update service:

net stop wuauserv

Type the following to restart the service:

net start wuauserv
| improve this answer | |
  • If it doesn't work via services what makes you think this will work instead? – DavidPostill May 11 '16 at 19:46
  • Thanks Matthew. When I do that, I get: The service is starting or stopping. Please try again later. (It's been over an hour since I tried stopping the service.) – RockPaperLz- Mask it or Casket May 11 '16 at 19:46
  • Ok. Have you tried running the Windows Update Troubleshooter? – Matthew May 11 '16 at 19:47
  • @Matthew I ran it last month, but I have not run it since then. – RockPaperLz- Mask it or Casket May 11 '16 at 19:49
  • Try running it again and correcting any errors it finds. Then run these commands again to see if the problem is solved. – Matthew May 11 '16 at 19:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.