9

I've tried to disable Background Intelligent Transfer service using two methods:

RegEdit and services.msc

After restarting the computer, the service runs at start-up again. How can I disable it permanently? Is there anyway to delete or get rid of this service? It consumes my internet and I would not like to download any Windows updates. I have Windows 10.

Thank you very much,

6
  • 1
    Have a look here on Unistalling BITS May 13, 2016 at 8:04
  • 4
    Doing this will kill Windows update, which means you could be left vulnerable in the event that security problems with various products are discovered.
    – Mokubai
    May 13, 2016 at 8:06
  • 2
    "After restarting the computer, the service runs at start-up again." It should not do this if truly disabled. Also disable Windows Updates in Services, see if this helps internet usage.
    – Moab
    May 13, 2016 at 19:25
  • 1
    Command: sc stop BITS & sc config BITS start= disabled
    – Biswapriyo
    Oct 26, 2017 at 20:41
  • Suggested workaround - superuser.com/a/1592658.
    – Henke
    Nov 21, 2020 at 18:52

6 Answers 6

8

In order to disable Background Intelligent Transfer Service (BITS), you have to follow these steps:

  1. Press Win + R (or Start => Run)
  2. Type msconfig and press Enter
  3. Select Services tab
  4. Locate Background Intelligent Transfer Service
  5. Remove the tick next to it.
  6. Press Apply
  7. Reboot the system.

There might be some overall performance improvement, however, in my personal case it made large file transfer slower despite the fact that it was Core i7 3rd gen.

5
  • 1
    Thank you very much for your answer. What do you mean by "remove the check mark" ? I did not found "Background Intelligent Transfer" , Do you mean all the check marks? What I found is "Background tasks infrastructure service" and "Windows update". Is one of them related to me issue? May 13, 2016 at 10:16
  • 4
    do not accept the wrong answers pls. Apr 28, 2017 at 16:57
  • It works for me. What are the drawbacks of disabling this service? Will some of the system functionalities be affected?
    – vineeshvs
    Jun 14, 2020 at 2:55
  • 1
    @vineeshvs, superuser.com/questions/1072771.
    – Henke
    Nov 21, 2020 at 16:02
  • This works for me. and increases my download speed Thank you Jul 26, 2021 at 7:24
2
  1. First open services
  2. open properties of background intelligent transfer service
  3. click stop and in startup type choose disabled
  4. on the recovery tab choose take no action for first and second failure
  5. click ok and the service will never starts again.
1
  • Generally that's how it works. But, somehow in my asus laptop (personal), it's running on next start & it's not in disabled state also. Strange!! Apr 17, 2021 at 5:50
1

BITS is one of the crucial services to download Windows Updates. Disabling this service will interrupt Windows Updates installation which is not recommended. Here, there is no permanent way to disable Background Intelligence Transfer Service. However, I would suggest to you follow the steps below and check if it reduces CPU utilization.

Method 1: Install all the latest Windows Updates.

Method 2: Try Clean Boot   Special Note: After troubleshooting, refer to this section How to reset the computer to start normally after clean boot troubleshooting

I hope this helps definitely

For more details -http://answers.microsoft.com/en-us/windows/forum/windows_10-performance/how-do-i-permanantly-disable-bits-background/61ed6216-15d2-4b2b-ae82-a20e61d57d3b?auth=1

1
  • Agree, but it could be nice if windows update would not take 100% of bandwidth, making it impossible for other software to do some networking at all.
    – jokoon
    Nov 22, 2016 at 12:34
1

None of the above tips worked for me, stopping the BITS service, setting mode to disabled, setting recovery to no action etc. BITS keeps turning itself back on and eating up my data. I finally found a way to stop the service , here goes :

  1. Create a new user in your windows with some password
  2. Go to services.msc -> BITS
  3. Right click properties and go to the logon tab, select local account and provide the new user name with a wrong password
  4. Go to general tab and in Start up type select disable

BITS is stopped for ever.

1
  • Won't last forever. These settings automatically get reset after few days and BITS is back in action. Oct 11, 2020 at 13:51
1

None of the answers worked permanently as BITS gets enabled after few days. But good news is, we can set bandwidth consumption of BITS to 0kbps and restrict it from eating up internet speed.

This is the only trick I found to control BITS and it worked perfectly for me.
So here you go,

  1. Open start menu(or press windows key), type gpedit.msc(Edit group Policy) and open it.
  2. Navigate to Computer Configuration > Administrative Templates > Network > Background Intelligent Transfer Service (BITS)
  3. Edit(double click) Limit the maximum network bandwidth for BITS background transfers.
  4. Now select Enable and change Limit background transfer rate(kbps) to to 0 or some lower value like 2. Remember you need to set this at 2 places on same screen, one for scheduled time and one for all other times.

That's it. BITS will now use only the bandwidth you have specified.

Note: This might not work in windows Home edition. If works for someone please comment/edit answer.

1
  • gpedit.msc is a good option, however, Group Policy isn't available by default on Windows 10 Home editions. There are some workarounds, which allows you to enable Group Policy, but it will be wiped out on the next windows update (such as 'Fall Creators update')
    – Malakai
    Jan 8, 2021 at 20:38
0

Try disable windows update service in services and if not work to ensure disable windows update services in msconfig on services tab. This solved my issue.

1
  • This does not work. After 8 months of being disabled, windows managed to re enable the service. I have tried disabling BITS, WUASERV and some update orchestrator service too. I now have ownership of the windows update software repository and have disabled all reading and writing to the directories. I have also done this to the Windows10Upgrade directory so it cant update. What I want to know is how, after 8 months, it managed to re enable without ANY interaction. My day job is IT Technician
    – Adsy2010
    Dec 18, 2017 at 21:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.