I received a USB-Dongle for licensing a software product. My goal is to use the software in my virtual machine on VMWare Workstation. (Because i need to access the API of the software in my development machine)
Sadly i'm unable to connect the dongle to my virtual machine. My VMWare Workstation menu lists the device under "VM > Removable Devices" but when i try to connect the device, it shows the following error:

The connection for the USB device xxx was unsuccessful.
The device is currently in use.

What i did until now:
I installed the custom drivers that came with the dongle on my host and my guest operating system. The dongle's red led then started flashing, indicating that the device is operational now (sadly only for the host). I tried different things like

  • Only installing the driver on the guest operating system (I thought then it might not be in use at the time i'm trying to connect it to the virtual machine. But then it showed an "Driver error" when trying to connect the device)
  • Deactivating the device in the Device-Manager (Didn't work either, the device's led stopped flashing, but VMWare is still telling me that the device is still in use)
  • Killed all processes that obviously relate to the device (But i cannot assure that the ones i killed are enough)
  • I searched for the option to "safely remove" the device, but couldn't find anything.
  • I tried plugging the device in, before AND after i started the virtual machine, no differences.
  • I found a compatibility list (sadly for ESX/ESXi, not Workstation) from VMWare that shows that an earlier version of the dongle (3.21) is at least compatible with ESX/ESXi, so it might not be that unlikely that mine should work too. But couldn't find a similar list for workstation.

Sadly i do not have an idea how to get the device through to the VM. Do you know if there is a possible way to achieve that, or should i contact the vendor of the device with this problem? (Which i'd preferably like to avoid)

Some additional information about versions and stuff:

  • VMWare Workstation 9.0.0 build-812388
  • Host OS: Windows 7 Professional Service Pack 1, 64-bit
  • Guest OS: Windows Server 2012 R2 Standard, 64-bit
  • Dongle: Aladdin Knowledge HASP HL 3.25
  • Dongle Driver installed: Sentinel HASP/LDK v7.32 (This version was shipped with the device, but i also tried installing the newest version available (7.41) - without any effect)

If you need any further information that would help answering this question, feel free to comment!

  • Did you plug the device in after you booted into the VMware machine? May 13, 2016 at 9:47
  • @NetworkKingPin At first yes, but i also restarted the machine and the workstation after i plugged the device in. May 13, 2016 at 9:49
  • Alright because from my Experience working with VMware it Windows will keep the device on the main machine unless you unplug it and plug it in while you are in the Virtual machine. May 13, 2016 at 10:08
  • As I understand it, the VMWare USB "passthrough" is not a real passthrough, although it may depend on the VMWare product / version. I seem to recall it provides virtual USB 2 ports for compatibility reasons, rather than providing the USB ports provided by the host. It may well be that the mapping doesn't work well in your case; the behaviour while the driver is installed on both host and guest is supicious. Dongles tend to try to deploy methods beyond mainstream to make it difficult to copy them or provide their output to several machines.
    – Run CMD
    May 13, 2016 at 10:43
  • Uninstall the Hasp driver on the host
    – Elliott B
    Nov 6, 2019 at 9:06

2 Answers 2


Although the question is a few months old, this might help, or help someone else.

Try a different approach. Instead of trying to attach the USB dongle, which it sounds like you can't get to work, use pass-through on the USB controller itself (or add a small cheap USB card and then pass through the PCI device for the card), so your VM gets exclusive unmodified control of the USB hub/controller itself. That way your VM gets an unmodified view of any devices attached to it.

You won't be able to connect/disconnect the dongle from host as usual (because the hub itself is grabbed for that VM) but that's rarely if ever a problem because most PCs have multiple USB controllers, and adding another is very cheap, and you can manually move the device to a USB port that's not passed through. Should work for any USB device.


Stuck on the same problem on a Virtual Machine created with VMWare and (old CodeMeter version: CodeMeter-6.20.2147-500

I realize that something is wrong when command /usr/bin/cmu --list-content wasn't showing local CmContainers

Installing the latest and the greatest CodeMeter (downloaded from their website) solved the issue. I had as OS Mageia 6 x86_64 (rpm based) and command did the job:

[root@yatebts ss7ware]# rpm -vhU CodeMeter-6.80.3312-500.x86_64.rpm

Hope this answer will help other users.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.