As I am trying to change my wireless IPv4 or DNS IP address, everything goes well until I click OK.

The adapter window pops up this error: "An unexpected condition occurred. Not all of your requested changes in settings could be made"

Picture of the error message

Even when I restored Windows, disabled and re enabled the adapter, the problem was not solved.

Any help would be appreciated.

Edit: I fixed that by resetting Windows 10. No other solution worked for me.

  • If I recall correctly, I had similar issue in the past and "fixed" it by temporarily disabling/deleting virtual machine connection. Tho it could be for M$ VM, not vmware. – PTwr May 13 '16 at 15:00
  • I tried that but it didn't work. – Joker 00 May 13 '16 at 15:11
  • Make sure you have the latest drivers atheros-drivers.com/… – acejavelin May 13 '16 at 16:12
  • I checked, I do have the latest version. – Joker 00 May 13 '16 at 18:16
  • Do you have vmware installed on this machine? – hkdtam May 13 '16 at 19:11

Try to remove the "Bridged" entry from VMWare's program called "Virtual Network Editor"

| improve this answer | |
  • That didn't work too. I even tried to uninstall VMware but it didn't help. – Joker 00 May 14 '16 at 6:18

When all else fails troubleshooting a network issue, you can always remove and re-add the network adapter.

Press Win+X, select Device Manager. Open up Network Adapters and right-click your network adapter and select Uninstall. Since you said you have VMWare, I would uninstall those virtual adapters as well, as well as any other virtual adapters tied to the physical NIC.

Once that is done, reboot and let Windows redetect the NIC and install the drivers. Once that is complete, you can re-setup the VMWare virtual NICs.

| improve this answer | |
  • How to re-detect the NIC and install the drivers ? Because I did that but I couldn't be able to reinstall the driver (I have Acer Aspire E 15, I downloaded its driver from the official website and installed it but it didn't work). So I had to restore previous status of Windows. I guess the problem is in the part of "re-detect the NIC", how to do that ? – Joker 00 May 14 '16 at 6:16
  • The driver is already there. You just removed the device and Windows will reflect it. – Keltari May 14 '16 at 6:17
  • Okay! So how to re-detect the network interface card ? – Joker 00 May 14 '16 at 6:24
  • I would hair reboot – Keltari May 14 '16 at 6:24
  • Hair reboot? What's that? – Joker 00 May 14 '16 at 6:25

I had the same issue. I solved the problem by opening a password secured Harddrive, which contained a Virtual Box.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.