1

long time lurker first time asker. I have a very weird problem, whenever I try to connect to a specific machine on my network from my desktop with Windows 10 I get an error right off the bat.

PuTTY Fatal Error Network error: Software caused connection abort

But the weird part is, this only happens when I try to connect to this machine (a banana pi) from my desktop when running Windows 10 and using putty, with another client it works fine, when I try to connect to the BPi from my girlfriends notebook I have no problem, when I try to connect from my Linux Mint install on my desktop, no problem, when I try to connect from OS X Yosemite from my desktop (hackintosh), no problem, when I connect through ssh to either of my RPi's and through them connect to the BPi, no problem. The issue seems between PuTTY on the Windows 10 install and the BPi. I'm running Debian 8.3 kernel version 3.4.108-bananian on the BPi. Any help would be welcome.

Edit: I was made aware of a 64bit version of PuTTY, downloaded it and lo and behold, it works, recognized all the settings of the 32bit version and all. No idea as to why the 32bit version refused to work (always worked on my previous 64bit installs). But at least now I don't have to use another client just for this machine or connect to another machine, then from that machine connect to the offending one.

  • 1
    Are you using a 32 bit putty binary? – hkdtam May 13 '16 at 16:28
  • I didn't even know there was a 64bit version of putty, all I ever saw in the oficial(?) download page was the 32bit binary. After your comment I searched for a 64bit version, downloaded it and lo and behold, it works. – sanosuke_kursch May 13 '16 at 18:33
1

That's quite odd. My guess is that it's the RPi or Debian not agreeing with Putty. I'd suggest trying a different ssh client - http://www.htpcbeginner.com/best-ssh-clients-windows-putty-alternatives/2/.

  • My Windows 10 desktop can connect via Putty to my Ubuntu Server 14.04 just fine, so it's not a Win10/Putty compatibility problem.
  • Your RPi/Debian is able to communicate with other clients, so there isn't incompatibility there.
  • So my best guess would be an incompatibility in Putty with your receiving system.

    Best of luck, and let us know if a different client does or doesn't fix the issue.

1

the putty client is timing out hence the remote host assumes the session has terminated. on putty you can simulate activity on putty by sending null packets to the server

this is done by setting keep alive to more than 0 (0 means keep alive is turned off) as shown enter image description here

source: http://www.nth-design.com/2010/05/10/using-keepalive-in-putty/

  • Apparently that is the case only when you get that error after you're connected, in my case I got the error as soon as I tried to connect. Anyway, I used another binary and now I'm able to connect, go figure. – sanosuke_kursch May 14 '16 at 1:24
  • @sanosuke-kursch you should past that as an answer and accept it for future user having the same issue – brotich May 14 '16 at 14:27
  • But that was not the right answer, I already tried that. You see, keepalive is useful to, well, keep the connection alive while idle, but to keep it alive you need to have a connection in the first place, and I wasn't able to connect, hence this answer wasn't applicable to my problem. Also, what resolved my problem was using another binary, and I only remembered to do that because @hkdtam asked what binary I was using. So, at most the answer to my question was his question. – sanosuke_kursch May 14 '16 at 22:01
  • maybe i didnt communicate well...i meant the solution that worked for you is the one to post as an answer and mark it so..not mine. do that then i delete my answer. cheers – brotich May 15 '16 at 16:20
  • Can I even mark a comment as an answer? – sanosuke_kursch May 16 '16 at 23:05
-1

I just used another binary and puff, the problem was gone. Not sure what was causing it, though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.