9

My Acer laptop running Windows 10 has a very annoying feature: when running on battery, the LCD backlight dims gradually when displaying a dark screen and brightens gradually when displaying light screen.

This is especially annoying when switching between my IDE (which is dark and pleasant to the eyes) and a webpage.

I've figured out that this is happening only on battery, and no matter the display brightness, it happens unless I plug it in. I've checked if there's some setting in the Windows power settings, but nothing popped out at me (my laptop for instance doesn't have adaptive screen brightness).

15

An obscure forum post pointed me in the right direction:

  1. Search Windows for 'Intel'
  2. Select 'Intel HD Graphics Control Panel'
  3. Click the 'Power' square button
  4. Click 'On Battery' tab
  5. Disable 'Display Power Saving Technology' (I see it as the last option)

Here's the option in Intel's HD Graphics Control Panel:

Intel HD Graphics Control Panel: Display Power Saving Technology

Save your eyes and turn off "Display Power Saving Technology".

  • 3
    Another way to open Intel HD Graphics Control Panel is to right click on your desktop and select Intel Graphics Settings. I'm glad I found this answer. I couldn't stand the strain this has caused my eyes a few months. – hemantv Dec 17 '17 at 17:02
1

Such annoying feature in Philips BDM4065 monitor was caused by its "SmartContrast" setting turned on. Turning it off resolved the problem completely.

(This is not an advice for built-in laptop screens, but plenty of people looks here and part of them searches for the info pertaining to attached monitors.)

  • On the Samsung monitor we had it was called MagicBright, and it was set to Dynamic Contract. Annoying. – Scott Whitlock Nov 26 '19 at 18:16
0

I had a very similar problem using a ThinkPad T460s and a NEC MultiSync EA273WMi monitor. Using dark themes in my IDE the screen dimmed after a few seconds.

My problem was resolved by changing the "DV Mode" on the screen from "Dynamic" to "Standard".

0

I had this problem, tried all the suggestions but without success. I was using a widescreen TV as a second VDU for my laptop and always had the lid closed on my laptop. The dimming of the screen was particularly annoying when using VLC. Then by chance I had the lid open and noticed the laptop screen was OK with VLC. The problem was with the TV. The backlight option was set to AUTO. Once this was changed no further problem.

0

For anyone who doesn't have the Power Saving Technology option in Intel Graphics Control Panel (I only had a Panel Self-Refresh Enable/Disable option) follow the instructions in the first answer, from AMART53, in this forum, https://forums.intel.com/s/question/0D50P0000490XXpSAM/disable-intel-display-power-saving-technology-in-plugged-in-mode?language=en_US.

I have copied the answer below.

AMART53:

"launch regedit

go to :

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class{4d36e968-e325-11ce-bfc1-08002be10318}\0000]

(for me it was in 0001)

find the value FeatureTestControl

Open the calculator in programmor mode, go in HEX and write the value written, look at the binary, it give you for example:

HEX : c200

BIN : 110000100000000

change the 5th bit from the end to 1:

1100001000010000

Put in on calculator in programming mode/BIN and get the HEX value

BIN : 1100001000010000

HEX : c210

modify the register with regedit and put the new HEX value in FeatureTestControl

Restart your computer"

This worked for me although it seems insane something as specific as changing 1 binary digit would be needed to solve the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.