5
  • Win 10 Professional.
  • Surface Pro 4.

    I want to DISABLE, the right/left edge-swipe (technical jargon, unknown to me).

    I use my OneNote-2016 all the time for taking notes and so I am writing on the screen as the SurfacePro4 is made to do. All the time my arm is swiping the left or right edge and these swiping gestures keep opening up and destroying my productivity.

Images for clarity below.

Ref to (image-1): Red rectangle is the area in which my hand or arm "swipes" and causing the action that is in the image; the same action can be acquired by touching the button/icon in the smaller red rectangle in the image. In this image the Action is "Task View".

(image-1) Left Edge Swiping Gesture Left Edge Swiping Gesture


Ref to (image-2): Red rectangle is the area in which my hand or arm "swipes" and causing the action that is in the image; the same action can be acquired by touching the button/icon in the smaller red rectangle in the image. In this image the Action is "New Notifications" and/or "Action Center".

(image-2) Right Edge Swiping Gesture Right Edge Swiping Gesture


*Note: On the System and OS I've listed on the top of the page, mouse/touch, "Device Settings", nor do "Synaptics Device" exist; DNE (does not exist). An image below to demonstrate the accuracy of this: enter image description here

  • You can't. These gestures are basic functionality of the tablet mode. I hate to say this but I have a SP3 and I used it as my sole source for note taking with my MBA and I never had this problem, and there is no practical difference between SP3 and SP4 with regards to that. I even used Windows 8.1 before I upgrade to Windows 10( still didn't have problems) – Ramhound May 14 '16 at 1:34
  • @Ramhound I'm not using my Surface Pro4 in Tablet mode. Note in (image-2), Tablet Mode, is turned off. I never use that mode. – ejbytes May 14 '16 at 1:47
  • Well you do have rotation locked enabled. But that doesn't change my response about the gestures – Ramhound May 14 '16 at 2:12
  • 1) Symnaptics is a manufacture of touchpads not touchscreen so it's not clear why your looking for that option to change the gestures on your touchscreen 2) this might help don't feel like powering up my SP3 and yes it's Windows 8.1 but that control panel applet still exists – Ramhound May 14 '16 at 2:19
  • @Ramhound I have rotation locked to stay in Portrait mode, but the problem persists w/w/out rotation lock. I only mentioned Synaptics because any solution I found on the web mentions it in a couple dozen scenarios. And so to avoid "hasty responses", it's clearer to nip it in the bud. I'm glad you, personally, didn't have any problems with your device, but mine does open up those left and right window panes when brushing up on them during a writing session on OneNote. – ejbytes May 16 '16 at 22:35
2

I found a solution called Skip MetroSuite

http://winaero.com/comment.php?comment.news.103

I checked all the boxes and now theres no swipe gestures on any edges. It's amazing.

  • Hey, that looks promising. I'm working on a project, but later on I will check this out. "Charms Bar"? Who would have thunk it! That's the thing about technology in general, if you don't know how to ask the right question, you really can't get the right answer. I guess the problem is "Charms Bar". Nobody chimed in about "Charms Bar", because nobody knows the damn nomenclature! Thanks for chiming in! – ejbytes Jul 13 '16 at 2:51
  • [+1] I upvoted so far, because I don't know if this is a solution yet. If it turns out to work and solved the problem, I'll check it and let you know. I think an upvote will at least give you some rep points for now. -- Turns out it's not "Charms Bar" after all, but thanks for helping out. – ejbytes Jul 13 '16 at 3:08
  • Windows 10 does not have Char Bar functionality though. The tool also only is designed for Windows 8.0. – Ramhound Jul 13 '16 at 11:41
1

I found a solution to this on Windows 10 (14393.576) for Surface 4.

(see screenshot below)

  1. Edit Group Policy,
  2. Go to Administrative Templates/Windows Components/Edge UI
  3. set "allow edge swipe" to "Disabled"
  4. restart enter image description here
  • will this also disable the top and bottom edge swipes? I.e. to access the taskbar in fullscreen mode – lucidbrot Oct 20 '17 at 10:56
1

If you go to settings > Devices > Pen & Windows Ink, there is a little box under pen options "Ignore touch input when I'm using my pen" and if you check this box it should help. I was having the same issue with using my writing on PowerPoint presentations, it would change slides while I was taking notes for the class, but it stopped when I checked this box.

  • Dusty, I haven't turned on my SP4 in a while, but since this is my post I'll check it out when I fire up my SP4 again. I'll give you a one-up to help you get some abilities to be able to help out more. Although I did finish my math courses and after an update I think it was an issue that perhaps got dealt with internally (internal as in a known bug issue within Microsoft); not sure. Thanks for chiming in. This post must be on a list of "unanswered", just beware of the dates, also beware of the people that post and split, sometimes in the past I'd put some time in and the person turned ghost. – ejbytes Oct 14 '18 at 23:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.