30

Possible Duplicate:
Stop PDFs from displaying inside Google Chrome

Chrome is opening the PDF files automatically and don't give option to save the file. How can i change this behavior?

marked as duplicate by Arjan, BinaryMisfit Dec 9 '10 at 8:16

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

migrated from stackoverflow.com Feb 11 '10 at 20:41

This question came from our site for professional and enthusiast programmers.

  • 3
    In general, if you want to save the target of a link, you right-click on it and select to save the target of the link. – Anon. Feb 11 '10 at 20:40
  • possible duplicate of Stop PDFs from displaying inside Google Chrome (A bit late to vote to close, but it seems Adobe Reader might be the culprit; see the other question.) – Arjan Dec 9 '10 at 7:48
  • 1
    "right-click on it and select to save the target of the link" -- doesn't work if the target is an html script page that does the download. – Jim Balter Sep 5 '15 at 20:26
  • 2
    This is not a duplicate. Opening in browser is addressed in the other. this was directed at opening in Adobe Reader, rather than just download. (The second problem was encounter and not answered in the linked question, but was addressed by @r0ca here) – Eric G Dec 7 '15 at 21:52
  • Also on mobile. Is that a gimmick? If yes, then certainly no good one. – neverMind9 Oct 24 '18 at 2:35
26

Open chrome://plugins/ in the browser and disable the PDF Viewer plugin.

  • I also had to disable the Acrobat plugin – Philipp Jan 22 '14 at 9:23
  • 1
    Just for reference, the PDF Viewer plugin checkbox is now disabled from being toggled by the user. – Taylor Edmiston Feb 12 '17 at 20:46
  • chrome://plugins/ is not available in Chrome 57+. – zylstra Aug 14 '17 at 20:25
  • 1
    Currently you can set this setting at chrome://settings/content/pdfDocuments – JohannesB Mar 13 '18 at 11:03
20

Try this:

  • Go to 'Options'
  • Then go to the tab "Advanced"
  • Click "Clear Auto-opening settings"
  • 3
    The URL chrome://settings/advanced brings you to the same options page. – Niall Murphy Dec 2 '11 at 17:50
  • 2
    This is the only one that seems to address the issue for me, but it does not work for me. Clicking PDF links still opens them in my PDF viewer. – Tanath Dec 22 '16 at 15:09
  • 1
    @r0ca, You are the only one understood the question (It is not about Chrome's PDF Viewer). Yet, it seems even if I clear this option it won't stop opening PDF's after they were downloaded. Any idea? – Royi Jan 31 '17 at 11:10
  • Moreover, If I try, while the file is being downloaded, to disable the option to open it, it won't work. See i.imgur.com/AzlBBmb.png. Though I click on the V sign to disable it, nothing happens. – Royi Jan 31 '17 at 11:23
  • 3
    It seems there might be something in Content Settings: imgur.com/MWLyY85 – Royi Feb 2 '17 at 16:16
5

Just go to Extensions and disable the Docs PDF/PowerPoint Viewer extension.

2

By default, Google Chrome will usually download files into "My Documents/Downloads", but if you want to save a PDF document into a specific folder simply right click the link and select "Save link as...".

Alternatively you can go to options, then to the "Under the bonnet" tab, then click the check box "ask where to save each file before downloading".

  • You misunderstood the question, which was about Chrome opening the PDF file for display, instead of downloading it. Your response has nothing to do with PDF files. Also, the default location where Chrome stores downloads is found and can be set on the Advanced Settings page, along with the "ask where to save each file before downloading" checkbox -- which is rather annoying when you turn it on. It's better to right click and click "Save as...". – Jim Balter Sep 5 '15 at 20:22