I prefer my keyboard repeat rate and delay to be as high as possible. I've always enjoyed immediate response when typing or holding a key.

I'm not sure why this is happening or if there is any correlation in when it occurs, but my keyboard repeat rate and delay keep reducing to a very low level (presumably default settings). But the Keyboard Properties never reflects whatever changes are occurring.

keyboard properties

Every time these settings slow down, I'm forced to go back to these settings, and toggle one of the settings lower and then higher so I can Apply those settings. This resolves it, but it eventually returns.

How can I resolve this?

up vote 4 down vote accepted

To get around this you could use the "Filter Keys" feature in the Ease of Access center to speed it up. Of course backup your registry before doing this or at least back up the values so you can roll it back if it isn't doing what you want it to do. Go into regedit.exe navigate down to HKEY_CURRENT_USER\Control Panel\Accessibility\Keyboard Response and update your values. Reboot for the changes to be seen.

[HKEY_CURRENT_USER\Control Panel\Accessibility\Keyboard Response]
"AutoRepeatDelay"="200"
"AutoRepeatRate"="6"
"DelayBeforeAcceptance"="0"
"Flags"="59"
"BounceTime"="0"
  • And what if I don't have "Accessibility" under "Control Panel"?? And I don't have "Keyboard Response" anywhere in the registry. How can I resolve the issue of the keyboard settings, in such a case?? – TheCuBeMan Mar 22 '17 at 11:27
  • 1
    had exactly the same problem on Windows 10 and this fixed it. I set AutoRepeatDelay=200, AutoRepeatRate=30 and kept the others (e.g. Flags=126). thanks so much – user829755 May 7 '17 at 16:55
  • 1
    The "59" is the minimal flags that will enable reading for the delay and rate set in regedit (it is the result of setting Filter Keys - On and Display Filter Keys Icon on the Task bar. Do not access or change these settings (or any settings related to the keyboard) or the registry entries for rate and delay will be reset to defaults (0). Personally, I prefer 264, 8 for the delay and rate. If you do access the Accessibility settings, keyboard repeat will be disabled until you log out and in again. If you change anything, values are reset to default. – David C. Rankin Jun 24 '17 at 3:54
  • From what I can tell, Display filter keys (32) and toggle sound (16) is unnecessary, and in fact only 3 (On + Available) is sufficient and far less annoying. – SilverbackNet Feb 24 at 23:38
  • solution seems to have been improved at ludditus.com/2016/07/15/… – ypocat May 23 at 21:44

I set next values in Windows 10 registry:

Windows Registry Editor Version 5.00    

[HKEY_CURRENT_USER\Control Panel\Keyboard]
"KeyboardDelay"="0"
"KeyboardSpeed"="31"

Remember to save the .reg as unicode.

And my keyboard became more fast!

  • 2
    technet.microsoft.com/en-us/library/cc978659.aspx KeyboardSpeed has a maximum of 31, anything above that is a placebo – Metalshark Apr 3 at 10:28
  • It is odd that changing the config in control panel updates the registry, and using a .reg file also changes the registry but the keyboard keeps the "old" config. If I open the keyboard proprieties, they are set to the old values also, different from the registry! Why that? – Pedro77 Apr 24 at 21:12

I had a key repeat problem with my Lenovo Yoga 11e Thinkpad, Windows 10. I thought it was a Windows 10 problem so kept trying to handle that. I didn't so eventually looked into the possibility of it being a hardware problem. In the laptop BIOs settings I found there was a setting to accept the OS's keyboard settings. It was on. I turned it off. I saved and rebooted. My keyboard problem was handled. I believe that this setting, when on, was creating a conflict with the Windows 10 settings which work well without being "told" to do so. I hope this might help someone else and save them the frustrations I had.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.