0

I have a Ubuntu 14.04 LTS 64bit guest OS running on VMWare Workstation 12 Player on a Windows 10 host. I was running Eclipse for a while recently when it got really slow despite multiple Eclipse restarts, so I decided to reboot the guest OS. It froze on the GUI desktop either shutting down or booting up, so I rebooted down using VMWare. After this, I kept getting kernel panics with the following errors:

run-init: /sbin/init: No such file or directory Target filesyste doesn't have requested /sbin/init run-init: /sbin/init: No such file or directory run-init: /etc/init Permission denied run-init: /bin/init: No such file or directory

I think my filesystem must have been corrupted somehow. I tried to boot into a Live DVD by loading the 14.04 DVD ISO as the DVD drive and checking "Connect at power on". I then started the VM and selected the DVD drive in the boot menu. However, it still booted up from my hard drive.

How do I fix this problem?

  • Is there any other way of accessing the guest OS file system? Perhaps by mounting the disk image which is probably somewhere in the VM files? – user1118764 May 17 '16 at 1:53
0

To try and recover without the ISO/DVD: Try powering on your VM and selecting "Recovery Options" from the GRUB menu (if present, otherwise see this link).

Booting from the DVD/ISO: While the VM is powered off, go to the VM settings and select the CD as the primary/only boot device. Alternatively, if VMWare supports it (I've been using Virtualbox for so long so I don't recall), you can manually select your boot device at power on (usually something similar to a PC like F9).

  • I already tried option 1 and that didn't work since I don't think it's a kernel problem but rather a file system problem(missing/corrupted init file and/or other system files. I don't see any options in VM settings to select the CD drive as the primary/only boot device. I did go into the BIOS once booted up via F2 and selected the CD drive as the first boot drive but that didn't seem to work. I also tried the boot menu via Esc no go either. – user1118764 May 17 '16 at 0:47
  • Only thing I can think of is: 1. Try another VM like Virtualbox which can import the VMWare hdd image see howtogeek.com/125640/… 2. Create a new vitual machine and add the damaged image as a secondary hdd to repair it (fsck it for more). 3. What you suggested in the first comment if there is a tool to mount the image on your host OS. – nonzyro May 17 '16 at 9:22

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.