0

I have several hyperlinks in an Excel 2010 sheet that are .png image files. I have .png files set to open in MS Paint. In Windows 7, clicking a link would directly open the file in MS Paint. But in Windows 8, using Internet Explorer 11, clicking the same .png link now opens internet explorer first, and displays an annoying message, "Image will not automatically be saved", and then the image opens in MS Paint.

Is there a way to bypass Internet Explorer, so that the hyperlink opens the file in the program associated with the extension, instead of always opening the file in Internet Explorer?

0

Do Windows Key + X

Click Control Panel

Go to Programs then under Default Programs look at Make a file type always open in a specific program

Click Associate a file type or protocol with specific program

Locate PNG, select it, then click Change program at the top right and select Paint. Close it out and you're done.

  • Hi Travis. I have .png files correctly associated to open in MS Paint. The problem is in Excel 2010, all my hyperlinks spawn an instance of Internet Explorer, and Internet Explorer will then ask me if I want to open the .png file in MS Paint. I don't want excel to always open all hyperlinks in Internet Explorer. There might be a setting in MS Office to change this behavior, but I cannot find it. – netcat May 17 '16 at 14:23
  • KB162059: support.microsoft.com/en-us/kb/162059 – Travis May 17 '16 at 14:33
  • Thanks, but these instructions are for having Internet Explorer open the office html links with the correct office app., i.e., Excel, instead of in Internet Explorer. The hyperlinks I have are already in MS Office, and Internet Explorer does use the correct program, MS Paint. I want office to not use Internet Explorer at all. – netcat May 18 '16 at 13:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.