0

I recently purchased a Razer BlackWidow Chroma RGB keyboard. It worked fine for a while using the Razer Synapse software to change the lighting effects and macros, but now whenever I launch Synapse with the keyboard plugged in, the software just says, "To get started, please connect a Razer Synapse enabled device". I have tried unplugging and plugging back in the keyboard, updating the software, and rebooting the (Windows 10 64 bit) system and it still doesn't work. The keyboard still works fine as a keyboard, but the Synapse software is required to use lots of its other functionality.

  • Have you contacted Razer for technical support? – Ramhound May 16 '16 at 18:10
  • Try what the people from Tom's Hardware have tried. By how many posts there are, this seems to be a common problem. (Not surprised, it's Razer) – DrZoo May 16 '16 at 19:59
0

Once you have Synapse already installed, go to your task manager and end any Razer Synapse related processes. Make sure to check the background processes also.

When you've done this, unplug your keyboard from your computer, then re-launch Synapse. Once you're greeted with the menu saying to connect a Razer device, plug your keyboard back into your computer and it should recognize it.

if that doesn't work you can Go to control panel- device manager- search for your razer device which might be under controllers or under unidentified usb device. right click and click uninstall. if that doesnt work right click - uninstall and click remove drivers also. then restart your computer , open razer synapse, connect your device and wait for synapse to detect it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.