2

I have an issue here, trying to install libopenssl-devel on a SuSE box. The installation is purely from DVD (no online updates involved).

$ sudo zypper install libopenssl-devel
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides libopenssl0_9_8 = 0.9.8h needed by libopenssl-devel-0.9.8h-30.11.x86_64
 Solution 1: do not install libopenssl-devel-0.9.8h-30.11.x86_64
 Solution 2: break libopenssl-devel-0.9.8h-30.11.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c):

Interactively, I would select option 2 (ignore dependencies), as the installed version of libopenssl is 0.9.8j, and the difference does not matter for my purposes. (No, really, it doesn't.)

The problem is that I would like to run the installation from within a script (Vagrant provider script), so...

How do I tell zypper to ignore a dependency, non-interactively?

1
zypper -n install --force package

-n = non interactive --force force install package

  • Figured that out myself and forgot about this question. :-D Have a checkmark! – DevSolar Dec 20 '16 at 11:31

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.