4

I have problem to make the clipboard works on my VM the informations is following

  • VirtualBox Version: 5.0.20 r106931.
  • Host: Ubuntu 16.04 VirtualBox Extension Pack installed.
  • Guest: Windows 10 Guest Additions installed.

i tried shutdown, reboot the VM many times and kill VBoxTray process but no help.

This is not a duplicate question i googled regrading the issue but no solution is found.

The screen resolution, shared folders and USBs are working as excepted.

How i can make it works ?

Update The clipboard is seated to Bidirectional. also it tried Host to guest + guest to host.

  • Have you actually enabled the shared clipboard? The important part is to go to the Devices menu at the top of the VM, then Shared Clipboard and select one of the options. superuser.com/questions/42134/… – Mokubai May 17 '16 at 19:50
  • @Mokubai Of course i did sorry i don't mention it – RepeatUntil May 17 '16 at 19:54
  • 1
    Fair enough, it would be worth editing it in to your question then. The only reason I asked is because I spent at least 15 minutes wondering why it wouldn't work a few weeks back and it seems an easy thing to miss. – Mokubai May 17 '16 at 19:57
  • Same issue. Seems 5.20 broke the clipboard. I am on a linux host as well. – Vans S Jun 1 '16 at 0:58
  • @VansS a workaround, Go to VM Options + Display + Remote Display tap + put any port number ( use random unique port for each VM ) . Connect to your VM using Remmina or any RDP client you like. – RepeatUntil Jun 1 '16 at 2:28
1

For me, OS X host virtual box 5.20, ubuntu 16.04 guest, bidirectional clipboard works with Ubuntu's Virtualbox guest package which is v5.18, but not with the Oracle extension (5.20)

| improve this answer | |
  • Normal start or Headless start ? – RepeatUntil May 30 '16 at 13:25
  • My Windows guest on Os x also has bidirectional clipboard... so I guess something is not correct on your host virtual box. – Tim Richardson May 31 '16 at 8:06
-1

I've always had the issue with virtualbox clipboard (bi-directional). My host is debian and guest is windows 7, and I just updated to virtualbox-5.1. I had the VBoxService process running instead of the VBoxTray even tho startup program VBoxTray was selected in

"C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools\System Configuration"

Apparently this happened due to the registry value not being set, to which it was pointing to.

location:

HKLM\Software\Microsoft\Windows\CurrentVersion\Run

value:

C:\Windows\System32\VBoxTray.exe

So I went ahead and created the string key in the same location, pointing to the same path, which autostarted the program on start up.

Bad news tho. clipboard does not work on headless, or detachable. One of the solutions is to connect remotely to the vm, which is ridiculous.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.