0

I am trying to install Linux on my Asus X205T netbook from a USB drive. Recently I used the same drive to install Ubuntu on a relative's laptop.

I formatted the USB drive on my Macbook Pro using Disk Utility (FAT) and then used Unetbootin to set up the drive with a CentOS 7 .iso that I got directly from the CentOS download page.

For some reason I cannot get this Netbook to boot from the USB. When I do advanced restart settings and choose to boot from the USB drive (UEFI) the thing just boots back up into Windows. I even tried restarting to the BIOS and changing the boot order there to have the USB drive as #1.

I also tried wiping the USB drive again and using Unetbootin to set up the USB with Ubuntu (just like I did for my relative) and tried the same steps above to boot the Netbook with Ubuntu instead of CentOS - still no luck.

I also tried something I found in another answer here, which is that Asus Netbooks allow you to press ESC during boot and choose what device to boot from. I did that and - once again - it saw that the USB drive was available but when I choose to boot from it I still was taken to Windows.

Anyone have any idea what I might be doing wrong, and why this Netbook can recognize the USB drive but won't boot from it???

0

There are a number of settings that may need to be changed in BIOS (UEFI) setup to force booting from a USB port:

  1. "Enable legacy USB support" or a similarly worded setting should be on.

  2. If the USB ISO does not support EFI, then set CSM mode (Compatibility Support Module) rather than EFI. 64-bit Ubuntu does support EFI, but I do not know about CentOS 7.

  3. Disable Secure Boot, which looks for a digital signature on the HDD.

  4. You may also need to disable Fast Boot, setting it to Normal Boot, though that setting is primarily for Windows OS PC's.

Let me know if this solves your problem.

  • Thanks for your reply. I've disabled Fast Boot in Windows settings and Secure Boot in the BIOS. As for #1, I am unable to find Legacy USB support in my Windows or BIOS settings. As for #2, I am currently attempting to use 32-bit Ubuntu because my machine is apparently 32-bit. Does that change anything? – sixty4bit May 18 '16 at 1:35
  • So I didn't realize it but when I upgraded this Netbook from Windows 8.1 to 10, the updater gave me 32-bit by default, but the hardware would support the 64-bit Windows 10. So I guess I should be able to use Ubuntu 64-bit. How do I set Compatibility Support Mode? – sixty4bit May 18 '16 at 1:50
  • For Ubuntu, use the AMD-64 release, even for a 64-bit Intel machine, and try first with EFI, rather than the less secure CSM boot mode. If that doesn't work, then you may need to resort to the CSM setting, instead. In any case, try running Ubuntu from the USB device without installing it, at first, to be sure the hardware is fully supported. If OK, then install for either solo or dual-boot use. – DrMoishe Pippik May 18 '16 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.