I'm having an issue connecting to a remote machine (Win Server 2012) using Remote Desktop.. but the weird thing is I only have trouble connecting from one machine that I use. I can connect from two other machines fine, even with the same credentials. From the problem machine (Windows 7), I am given a login prompt before seeing the error pictured at the end of the post. I can remote to several other servers from the problem machine without issue.

Things I've tried so far:

  1. Connecting to the remote machine using the fully qualified domain name
  2. Connecting to the remote machine using the IP address
  3. Logging in to the remote machine with the system administrator account
  4. Switching the problem machine IP to static and setting it to a known IP address from a "good" machine
  5. Deleting the default.rdp file in My Documents on the problem machine
  6. Checked everything in this help article... most of this stuff can be eliminated automatically because many other machines can connect. I did however double check Windows Firewall on both my machine and the server, as well the Network Level Auth settings on my machine.
  7. Checked the remote machine's Event Viewer logs. Nothing to be found in the log immediately after a failed connect attempt from the problem machine

Again... I can connect to this server just fine with my credentials on two other client machines (one is Windows 7, one is Windows 8.1). What am I missing here?? What else can I try to figure this out?

The error:

error image


Group policy settings on the server:

group policies

The only thing that is configured is the Network Level Auth requirement, which I confirmed on the "problem" machine by following steps in my above linked help article.

  • Are you sure the 1 problem machine isn't blocked by a firewall rule on the server ? What happens if you try to ping the server from the problem machine? – Tonny Jun 21 '16 at 19:28
  • @Tonny ping works from the problem machine – Borophyll Jun 21 '16 at 19:29
  • Is MTU the same on three connecting machines? Try lower MTU on that specific one. – Kamil Maciorowski Jun 21 '16 at 19:32
  • @KamilMaciorowski That would be a really special edge case if the MTU makes the difference. That would imply a mis-configured router between the problem machine and the server causing fragging issues. (RDP is always TCP, so should be fraggable under normal circumstances.) It's worth a try though.... – Tonny Jun 21 '16 at 19:40
  • @KamilMaciorowski I tried changing the MTU from 1500 to 1458 as well as 1430 - still not working – Borophyll Jun 21 '16 at 20:01

Since it's a Windows 2012 machine you are trying to remote into using a Windows 7 PC, it might be that you don't have all the necessary Windows Updates for TLS 1.1 & TLS 1.2.

Try installing this Windows Update (KB3080079)

Then restart your PC and attempt to initialize the remote desktop connection.

  • 1
    Bingo - this machine had issues with Windows Update a long time ago, downloading this individual update solved the problem. – Borophyll Jun 21 '16 at 21:18

The other two machines might not meet encryption level requirements that the server is configured for. If the server is configured to not allow non-encrypted connections, it will reject connection requests from older RDP versions.

Try that out.


  • I don't think Remote Desktop Session Host Configuration exists on Server 2012... I looked at the alternative listed in the article (group policies) and none of them appear to be configured. See edit to main post for a screenshot of those group policies – Borophyll May 18 '16 at 18:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.