0

My local Windows account is an account of Administrator type. Note that it's not the built-in account of Administrator name.

Before Windows 10 Pro upgrade, I was using Windows 7 Professional. In Windows 7, I had full Administrator privileges. If I run cmd, I get an Administrator Command Prompt rightaway. I could freely modify files in any way I want in C:\Windows and C:\Program Files using Windows Explorer windows that I opened normally.

After upgrading to Windows 10, the account is still of Administrator type, but suddenly all the privileges are more restricted. I have to explicitly open things in Administrator mode. If I run cmd, I get a normal Command Prompt. I have to right-click Start and select Command Prompt (Admin).

As for the system folders, any attempts to modify anything there by myself would simply fail silently. There is not even an alert about a permission issue, asking me to elevate and provide administrative access. Nothing, just completely silent.

I must add that I had the UAC completely disabled in Windows 7, but after the upgrade it was enabled again. So I changed the UAC setting back to "Never notify" (lowest setting), but this doesn't seem to have fixed the issue described here.

How do I get back to having full admin access by default? How did it work so flawlessly in Windows 7, but suddenly break in Windows 10? How can I fix it?

0

Warning: Security features exist for your protection. Disabling them puts you at a higher risk of various types of dangers. Only follow these instructions if you understand the implications and can implement your own security protocols in-lieu of the disabled security features.

The following answer was inspired by an answer to the question "Windows 7 Administrator user doesn't have Admin rights".

UAC is not completely disabled in Windows 10 even at the lowest setting. To disable UAC completely:

  1. Press Win-R to open the Run dialog.
  2. Open Registry Editor by running regedit.
  3. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
  4. Locate the DWORD value called EnableLUA and double-click it.
  5. Change the value to 0 and click OK.
  6. You will be prompted to restart your computer, so please do so.

How did it work so flawlessly in Windows 7, but suddenly break in Windows 10?

It looks like you made the above change in Windows 7, but forgot about it. And during upgrade, your change was reverted when Windows 10 reset the UAC security to the default level.

Starting with recent Windows versions, changing the UAC setting to the lowest level does not completely disable UAC. You may no longer get the UAC prompts but you still need to explicitly perform administrative actions in an elevated mode. Normal runs of processes will now run in user mode. If you need to provide administrative access to a process you need to explicitly run in administrator mode.

TechNet explains further:

Unlike earlier versions of Windows, when an administrator logs on to a computer running Windows 7 or Windows Vista, the user’s full administrator access token is split into two access tokens: a full administrator access token and a standard user access token. During the logon process, authorization and access control components that identify an administrator are removed, resulting in a standard user access token. The standard user access token is then used to start the desktop, the Explorer.exe process. Because all applications inherit their access control data from the initial launch of the desktop, they all run as a standard user.

After an administrator logs on, the full administrator access token is not invoked until the user attempts to perform an administrative task. When a standard user logs on, only a standard user access token is created. This standard user access token is then used to start the desktop.

After the above change, all processes will automatically run in administrative mode.

Disclaimer: No responsibility shall be retained by the author for any damage caused on your system by following the instructions above.

  • This doesn't work anymore. Windows 10 version 1803 onwards, your UAC settings simply reset after every reboot and the registry key goes back to 1. Sometimes it will go back to 1 while you're still logged on, and this revert after you reboot. – Rex Jul 25 '18 at 6:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.