20

A strange problem has developed on my Windows 10 machine. When I'm in Windows, if I click inside a certain area in the centre of the screen, the mouse click does not register, and if the cursor should change based on the content I'm hovering over, it doesn't.

Here is a demonstration of what I mean. In this GIF, I move my mouse into the area and attempt to select some text, but nothing happens. When I then move my mouse out of the area, the cursor changes to the correct "text selector" cursor and I can select the text fine.

Demo

The mouse wheel and clicks (left, right and middle) don't work while the mouse is in this area. There is a short delay after Windows startup before this problem begins, and it also doesn't occur on the Windows lock screen. I have two displays, but only my primary display is affected. How can I get my cursor to work properly again?

  • If you disconnect primary display does it occur in the other one? (if you swap displays does it occur on the same monitor, or still on the primary display?) When this started to happen? Did you changed anything on the pc around that time? – Máté Juhász May 18 '16 at 7:11
  • Maybe it is something like this or that. – Kamil Maciorowski May 18 '16 at 7:13
  • @MátéJuhász It started today, and I haven't changed anything. I'll test with disconnecting displays as soon as I can and then update my answer. – Aaron Christiansen May 18 '16 at 7:41
17

If you minimize everything (so as to not accidentally close the wrong application) then click into the empty space and press alt + f4 it will close that invisible application that's running.

| improve this answer | |
  • 1
    It worked for me. I was really wondering what could have caused it. How to detect that application? – Jayapal Chandran May 2 '19 at 14:51
  • 19
    This version was MY issue. Invisible window "on top". No malware, just SLACK. Minimized, then moved mouse across screen until right click gave "wrong" menu or back for "right" menu. To find app, I ran Windows Spy from AutoHotKey and again moved the mouse over desktop until Spy showed the name of the app (Slack). Stopped all Slack processes and problem disappeared. Generally I can run Slack with no issue. – HerbM Aug 14 '19 at 20:39
  • 13
    @HerbM It was slack for me too. Simply quit that from system tray. Everything works fine again. – bytestorm Aug 20 '19 at 18:18
  • 3
    I had the same issue with Slack as you... – suchoss Oct 11 '19 at 18:43
  • 5
    The same here, Slack was the problem. Killing slack.exe from task manager solved the problem. – Tides Oct 14 '19 at 10:06
4

The problem must've been caused by some sort of adware program, because I ran ADWCleaner and the problem was instantly resolved without the need for even a restart.

| improve this answer | |
  • Set this as solution, to mark the question to be solved. – davidbaumann May 18 '16 at 15:39
  • 1
    @davidbaumann I need to wait 2 days before I can do that, because it's my own answer. – Aaron Christiansen May 18 '16 at 16:49
  • Reboot helped me too. Mine started after a reboot after a video driver install. – Davbog Jul 25 '19 at 21:24
  • Ran ADWCleaner and the problem disappeared. – ivan_bilan Oct 12 '19 at 19:45
1

I had the same problem. In my case it was a malfunctioning of the AVIRA virus scanner and the area was in the top left corner of the screen. It obviously tried to open an ad window but the script got stuck.

I installed another virus scanner, deinstalled AVIRA and now everything is fine again.

It cost me about 4 hours to figure out what was actually going on... :-(

| improve this answer | |
0

Did you just upgrade to windows 10? Try installing the latest version of logitech setpoint
http://support.logitech.com/en_us/software/setpoint

| improve this answer | |
  • Thanks for answering, but no, I've been on Windows 10 for a while now, from a clean install. – Aaron Christiansen May 18 '16 at 7:39
-1

I know this thread is old but thought that I'd add that I was having this problem and after reading this thread I went into my settings and turned off the pop up blocker and the problem was instantly fixed

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.