I'm using Windows 10 Pro 64-bit.

My application (that was run as administrator) maps a folder from D drive to a network drive Z using the Windows Network API wnetaddconnection2().

When I opened File Explorer, I couldn't see the Z drive. However, when I opened other applications (e.g., Visual Studio) in Admin mode and browse to This PC folder, I'm able to see the Z drive under Network Location.

Why and how to solve this issue of mapped drives not showing up straight away after being mapped?


This issue does not happen

  • in Windows 7 OR
  • when my application is not run as administrator OR
  • after I restart explorer.exe OR
  • in Open file dialog in other applications (such as Word, Paint, Visual Studio, etc.)

Note: I have EnabledLinkedConnections set to 1, EnableLUA set to 1.

Tried Solution

One solution is to look into a program in Administrative tools called Local Security Policy and disable all the policies related to UAC in Security Settings > Local Policies > Security Options (Located in the bottom 15 policies of the list) except UAC:Behaviour..., UAC:Switch... and UAC: Virtualize...

However, I do not want to go down that route due to several issues occuring such as cannot open windows 10 app like Calculator etc.

up vote 1 down vote accepted

Because of the UAC, the Shell runs with standard user permissions, it can't see mapped drives which were configured from your application running with admin rights.

There is a workaround called enabling the option EnableLinkedConnections:

  • Click Start, type regedit in the Start programs and files box, and then press ENTER.
  • Locate and then right-click the registry subkey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System.
  • Point to New, and then click DWORD Value.
  • Type EnableLinkedConnections, and then press ENTER.
  • Right-click EnableLinkedConnections, and then click Modify.
  • In the Value data box, type 1, and then click OK.
  • Exit Registry Editor, and then restart the computer.

Or you can apply my hack to run Explorer as admin to also see the mapped drives.

  • I have actually already done the EnableLinkedConnections part (as stated in the question) so I tried your hack and it works. – Mark May 19 '16 at 1:26

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.