3

On my computer I have various PDF readers - I generally use Edge for PDF reading, but I also have Adobe Acrobat DC, and Foxit Phantom Editor.

I installed a trial of Adobe Acrobat first, and then Foxit Phantom, and decided to go with Phantom as my PDF editor. So I uninstalled Acrobat.

However, Acrobat was the set previewer for my PDF files in Outlook 2013 (because I installed it before Phantom). After uninstalling it, Outlook 2013 gives me

This file cannot be previewed because there is no previewer installed for it

but I know there is because Foxit Phantom includes one.

What can I do to set Phantom as the previewer?

Couple Of Minor Details

In Default Programs, Open With has been set as the following and the Acrobat Preview worked.

  • Open With Edge
  • Open With Acrobat
  • Open With Phantom

It is currently set as Open With Phantom

  • The Preview Handler is not included by default. Did you install it? – Daniel B May 18 '16 at 11:12
  • @CalvT Do you see any PDF preview handler registered at HKLM\software\microsoft\windows\current version\preview handlers ? – pun May 18 '16 at 11:22
  • @The_IT_Guy_You_Don't_Like yes there's the Foxit PDF Preview Handler and the Foxit PDF Preview Provider (XP) – CalvT May 18 '16 at 11:24
  • @DanielB I'm not actually sure - the link is interesting thanks. Only I have Outlook 2013, and it never previewed PDF files until I installed Acrobat if I recall correctly – CalvT May 18 '16 at 11:25
  • 1
    @The_IT_Guy_You_Don't_Like Yup I did - Just did again but still no go – CalvT May 18 '16 at 12:06
3
  • Within Microsoft Outlook, go to "File" menu and click "Options".
  • Select the "Trust Center" link.
  • Click on the "Trust Center Settings..." button.
  • Select the "Attachment Handling" menu.
  • Click on the "Attachment and Document Previewers..." button.
  • Locate the "PDF PreviewHandler" option from the "File Previewing Options" list, related to the program that you have installed that Outlook is currently using to preview files. File Previewing Options
  • When you disable the checkbox, that viewer will no longer be in use: Disabled viewer
  • Reinstall the software that you want to be the actual viewer/previewer/handler and restart Outlook
| improve this answer | |
0

Have you tried changing Phantom to being your default PDF viewer?

Assuming you are using Windows, you can make this change within Default Programs either in the Start Menu, Control Panel or by typing it in to Windows Search.

Once opened, select Associate a file type or protocol with a program, look for the *.pdf extension and select Phantom as your default application.

When you have made the change, try restarting Outlook and see if that has made a difference.

| improve this answer | |
  • Hi Brendon, thanks for your answer - If you look at the end of my question I put the following: It is currently set as Open With Phantom - I'll update my question so that it's clearer. – CalvT May 18 '16 at 11:47
0

In Windows 10, search for "Default apps"

enter image description here

From the Default apps screen, scroll all the way to the bottom

enter image description here

Click on Choose default apps by file type

enter image description here

Scroll down the file extension list to .pdf

Choose the app you want to open the .pdf file from Outlook

enter image description here

I am not sure how you pick an app that's not on the list though. Perhaps that's a different question. For me, I just needed to go from Microsoft Edge to Google Chrome.

| improve this answer | |
  • Hi, thanks for the answer! Unfortunately I've reinstalled windows (unrelated to this question) since I asked this, so no longer have the issue. However, I definitely had a default PDF program selected, and mentioned this in my question, so don't think this was the problem. – CalvT Apr 1 at 18:42
  • I'm including the wrong answer because "previewer" was not a strong keyword signal for Google when I searched for setting Default PDF viewer in Outlook. So, if anyone else has the issue, they may actually find this answer useful. I don't know why Microsoft is allowed to get away with writing such terrible software so often. – Sun Apr 2 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.