I am looking for an explanation on something probably stupid but that I can’t find immediately on Internet.


  • Classic home LAN.
  • Network:
  • No DNS server.
  • I installed 2 Raspberry Pi’s. One is functioning as media player (Kodi/OSMC) the other one as a syslog server (Raspbian OS).


Why can I ssh by NAME and IP the Raspbian syslog server and only by IP the Kodi mediaplayer?

I start an ssh session via putty on a Windows pc. I know that I can add the Kodi hostname and ip address into my hostfile on my Windows desktop with the direct result that I can also ssh by NAME into that device. But I’d like to know why I need this extra step for the KODI and why this was not necessary for the Raspbian OS.

  • 1
    Sounds like KODI doesn't support NetBios name resolution. That seems odd. Try ping -a <ipaddress> to see if it can find the name that way. Try nbtstat -n to see what names are being resolved by NetBios. – Moby Disk May 18 '16 at 14:28
  • Thanks for the quick reply Moby Disk. I'll give your commands a try later on. This morning on the train I came across an article talking about the avahi daemon. It seems to work like Bonjour zeroconf. I could give it a try this afternoon and do an apt-get install avahi-daemon. I will post the output of your commands and report my findings about avahi. – maxim May 20 '16 at 8:40
  • ping -a <ipaddress> showed a name for the Raspbian device, but not for the Kodi device. As for the nbtstat -n this gave none of both. I did a release/refresh with nbtstat-RR and then got my Raspbian device in nbtstat -c. Of course I didn't forgot to # my line in my hostfile on my Windows machine. I'll have a check at avahi now. Just out of curiosity. – maxim May 20 '16 at 12:39
  • Uh? osmc@osmc:~$ sudo apt-get install avahi-daemon Reading package lists... Done Building dependency tree Reading state information... Done avahi-daemon is already the newest version. avahi-daemon set to manually installed. 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded. So I have Avahi on the system, it's running but I still can't see my Kodi device when I do `ping -a <ipaddress>. Strange. – maxim May 20 '16 at 12:41


1) This put me on the right track: https://tektab.com/2015/11/07/setting-up-file-sharingnas-using-samba-on-raspberry-pi/

2) When looking for samba on my Kodi/OSMC device a saw a folder and files in /etc (/etc/samba/smb.conf for example) - so I thought Samba is fully installed on this system.

3) I decided to do a sudo apt-get update and a sudo apt-get upgrade followed by a sudo apt-get install samba. My guess was that the system would tell me nicely that this service was already on the system. But no, in fact he proposed an installation of samba and required xxMB of installation files. I continued and executed the installation. Instead of restarting the service I restarted the device. After reboot I did a ping -a <ipaddress> and in the reply I saw 'OSMC' in the first line. Now I was able to ssh by name.
I didn't changed a thing in the /etc/samba/smb.conf file. Default config.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.