0

I have an HP EliteBook that is sometimes docked.

When the laptop is undocked, I generally do not want the num lock to be on. It would prevent me from entering normal letters.

When the laptop is docked, I generally do want the num lock to be on, since my USB keyboard has a numeric keypad that I like to use for, you know, numbers.

Every time I dock or undock my laptop, I find that typing doesn't work the way I want and I then toggle the num lock.

Is there some way for the docked USB keyboard numlock to not turn on the silly laptop keyboard numlock?

Or, if there's no other option, is there any way to disable the laptop's num lock altogether since I'll probably never want to use it?

(I'm running Window 7 Pro 64 bit.)

  • Which operating system and release/version/edition? Unless you want to hack the hardware (which I wouldn't recommend), this is more of a software than a hardware question. – a CVn May 18 '16 at 18:04
  • @MichaelKjörling I've added OS info. I didn't think that would matter. This used to happen on my Dell laptop, but there was a BIOS setting I could change. I couldn't find one for this HP laptop. – Jeremy Stein May 18 '16 at 19:44
  • Possible duplicate of Permanently disable num lock in windows? – phuclv Nov 30 '16 at 13:33
  • possible duplicate: hit num lock when I plug in keyboard – phuclv Nov 30 '16 at 13:49
0

Create an archive like DisableNumlock.reg, and paste the code below:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Control Panel\Keyboard]
"InitialKeyboardIndicators"="0"
"KeyboardDelay"="1"
"KeyboardSpeed"="31"

[HKEY_USERS\.DEFAULT\Control Panel\Keyboard]
"InitialKeyboardIndicators"="0"
"KeyboardDelay"="1"
"KeyboardSpeed"="31"

When you want do ENABLE the numlock, create another archive EnableNumlock.reg and paste the code below:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Control Panel\Keyboard]
"InitialKeyboardIndicators"="2"
"KeyboardDelay"="1"
"KeyboardSpeed"="31"

[HKEY_USERS\.DEFAULT\Control Panel\Keyboard]
"InitialKeyboardIndicators"="2"
"KeyboardDelay"="1"
"KeyboardSpeed"="31"
  • This appears to be a registry change that turns off the num lock. How would I use it to solve my problem? – Jeremy Stein May 20 '16 at 2:33
  • Awnser edited. I think that is the best solution. 2 archives, to enable or disable the numlock. – Diego May 20 '16 at 10:43
  • 1
    I'm still not sure how this helps. I want the numlock to turn off when I undock. Now instead of remembering to hit the numlock key, I need to remember to run this script. – Jeremy Stein May 20 '16 at 15:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.