4

I use custom keywords to make a search on different search engines within my location bar. It works great. Except for one search plugin: sometimes, the keyword is simply reset, cleared. I have to set it again. And it can happen several times in a week.

I don't often shut down my computer and I've not been able to find out if it could be related. If I reboot my Computer, the keyword may still be defined. If I don't shut it down for a while (I mean for a certain unmeasured amount of time), it may be reset.

I've found out that this search plugin is not present in searchplugins directory under my profile folder. I thought it could be related, but there are only 4 search plugins in this directory, and the other search plugins not in there have no problem with their keywords.

I've also found out that this search plugin is not the same format than, for example, the PHP search plugin. They are both OpenSearch plugins, but not defined the same way and with different formats:

phpnet.xml definition:

<SearchPlugin xmlns="http://www.mozilla.org/2006/browser/search/" xmlns:os="http://a9.com/-/spec/opensearch/1.1/">

opensearch.xml of the website, which is :

<OpenSearchDescription xmlns="http://a9.com/-/spec/opensearch/1.1/"
                   xmlns:moz="http://www.mozilla.org/2006/browser/search/">

I try to understand:

  • why the keyword for this specific search plugin is sometimes reset to blank
  • where firefox stores the search plugin for this website if it's not in searchplugins directory (which is the case of other search plugins which work perfectly well and don't lose their keywords)

If any one has any clue, I take it!

1 Answer 1

0

Have the same problem. My guess would be that Firefox is running auto-update of search plugins and when that happens your custom shortcut is discarded. Seems like a bug.

That seems to be true for DevDocs. If you see into the search definition file you'll notice a tag <Url type="application/opensearchdescription+xml" ...>. This is used for updates.

There are two workarounds:

  1. Use a bookmark. This is fine when there is no auto-complete (suggestions).
    1. Go to the website.
    2. Search for search terms.
    3. Add a bookmark to the site.
    4. Replace search terms with %s in the url.
    5. Add a keyword in options of the bookmark .
  2. Create a copy of the plugin. When you need suggestions or you want the search to appear in search engines.
    1. Go to the website.
    2. View source and find a tag <link rel="search" ...>.
    3. Open and save xml file specified in the tag.
    4. Remove <Url type="application/opensearchdescription+xml" ...> and maybe also <Tags>...</Tags> from the xml file.
    5. Use Mycroft tool to import the xml file and install search in Firefox.
3
  • It only happens with one search plugin, always the same. Not with any other of the many ones I have... I think it's more probably a bug linked to the search plugin format.
    – Arcesilas
    Sep 7, 2016 at 21:22
  • Look at the search plugin definition. I would guess it has a <Tags>...</Tags> entry.
    – Nux
    Sep 8, 2016 at 7:57
  • No, it has not such entry. I don't really remember, because it's been a while now, but I think I already edited it to make it use the same schema as for php.net.
    – Arcesilas
    Sep 8, 2016 at 12:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.