3

I can't find /etc/php5/conf.d directory in my system.
Do they change catalog structure ?

I already read /usr/share/doc/php5-common/README.Debian.gz
There is information about linking /etc/php5/$SAPI/conf.d to central directory /etc/php5/conf.d which is not present in my directory

root@d0:/# ls -al /etc/php5/
razem 24
drwxr-xr-x  6 root root 4096 maj 20 10:50 .
drwxr-xr-x 68 root root 4096 maj 20 10:38 ..
drwxr-xr-x  3 root root 4096 maj 20 10:16 apache2
drwxr-xr-x  3 root root 4096 maj 20 10:50 cgi
drwxr-xr-x  3 root root 4096 maj 20 10:16 cli
drwxr-xr-x  2 root root 4096 maj 20 10:16 mods-available

root@d0:/# dpkg -l | grep php
ii  libapache2-mod-php5            5.6.20+dfsg-0+deb8u1      amd64        server-side, HTML-embedded scripting language (Apache 2 module)
ii  php-apc                        4.0.7-1                   all          APC User Cache for PHP 5 (transitional package)
ii  php5                           5.6.20+dfsg-0+deb8u1      all          server-side, HTML-embedded scripting language (metapackage)
ii  php5-apcu                      4.0.7-1                   amd64        APC User Cache for PHP 5
ii  php5-cgi                       5.6.20+dfsg-0+deb8u1      amd64        server-side, HTML-embedded scripting language (CGI binary)
ii  php5-cli                       5.6.20+dfsg-0+deb8u1      amd64        command-line interpreter for the php5 scripting language
ii  php5-common                    5.6.20+dfsg-0+deb8u1      amd64        Common files for packages built from the php5 source
ii  php5-curl                      5.6.20+dfsg-0+deb8u1      amd64        CURL module for php5
ii  php5-gd                        5.6.20+dfsg-0+deb8u1      amd64        GD module for php5
ii  php5-imagick                   3.2.0~rc1-1               amd64        Provides a wrapper to the ImageMagick library
ii  php5-imap                      5.6.20+dfsg-0+deb8u1      amd64        IMAP module for php5
ii  php5-json                      1.3.6-1                   amd64        JSON module for php5
ii  php5-ldap                      5.6.20+dfsg-0+deb8u1      amd64        LDAP module for php5
ii  php5-mcrypt                    5.6.20+dfsg-0+deb8u1      amd64        MCrypt module for php5
ii  php5-mysqlnd                   5.6.20+dfsg-0+deb8u1      amd64        MySQL module for php5 (Native Driver)
ii  php5-recode                    5.6.20+dfsg-0+deb8u1      amd64        recode module for php5
  • Isn't it located under cli/ directory? – Alex May 20 '16 at 9:28
  • It is, but what I need to do is to paste apc configure file to php. CLI is Comand Line Interface. So what I should do: create conf.d folder, paste file in cli/conf.d or apache2/conf.d or... cgi/conf.d ? – beginner May 20 '16 at 9:35
2

TL;DR: Look in /etc/php/mods-available dir and use sudo php5enmod

Yes, they have changed the directory structure.

/etc/php5/conf.d

was present in previous Debian releases and has been supported in Debian 7 (wheezy), but, starting with Debian 8 (jessie) you have to use the directory

/etc/php5/mods-available

In Debian 8 you are supposed to use php5enmod/php5dismod utilities to create/remove necessary symlinks in /etc/php5/cli, /etc/php5/apache2, etc.

For example: if in Debian 7 you could create /etc/php5/99-local.ini file and manually add symlinks to this file from /etc/php5/cli, /etc/php5/apache2, etc., now you must:

  1. create /etc/php5/mods-available/local.ini file
  2. add ; priority=99 line to that file if priority is important to you
  3. run sudo php5enmod local

Note that php5enmod is not included in normal user's path, so don't expect command-line autocomplete to know this utility.

2

If somebody has same problem:
Default ini file for apc is now located in: /etc/php5/mods-available/
Thank you for your time.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.