0

I've installed ConEmu on a Windows 10 64bits machine. It worked fine for a few hours. But today, while trying to start a simple cmd.exe shell, I get two errors message.

  1. in a dialog box, it says that

    16 bits application is not supported. Impossible to start or execute the program "\??\C:\Users[MyUserName]\cmd.exe" because it is incompatible with 64 bits version of Windows. Please contact the software editor to … bla bla bla.

  2. In the ConEmu terminal, it displays the following :

    Can't create process, ErrCode=0x000000D8,

    Description: Cette version de %1 n’est pas compatible avec la version de Windows actuellement exécutée. Vérifiez dans les informations système de votre ordinateur, puis contactez l’éditeur de logiciel.

    Current directory: C:\Users[MyUserName]

    Command to be executed: "C:\Users[MyUserName]\cmd.exe" /k "C:\Program Files\ConEmu\ConEmu\CmdInit.cmd"

    Press Enter or Esc to close console, or wait...

What's Working:

  • cmd.exe is OK if started standalone (aka [Win]+[R])
  • Other shells, commands or apps inside ConEmu are doing just fine (PowerShell, PuTTy, CygWindows, notepad++, etc.).
  • I can also start cmd.exe just fine from other shells (Powershell and CygWindows) inside ConEmu.

I tried to remove it completely, cleaning the directory, including clink addon and xml settings files in %APPDATA%. Still the same issue.

I'm no Windows expert. Do you have any idea where that might come from ?

  • 1
    What is the hell cmd.exe in Users subfolder? Isn't it a virus? Cmd.exe is always located in system32! – Maximus May 20 '16 at 10:52
  • That's the point. I don't see any cmd.exe inside the user subfolder. Is there the equivalent of the which command in windows ? – Florent May 20 '16 at 12:02
  • where cmd is the equivalent of which cmd – DavidPostill May 20 '16 at 14:56
  • I just wipe clean my user directory and it works fine new. However, I can't explain it. Thanks for your help. What is the best way to close a topic / mark it as resolved ? – Florent May 25 '16 at 8:28
0

Reinstall ConEmu

  1. Remove registry (download Microsoft Fix it utility and clean up registry)
  2. Uninstall from control panel
  3. Then Install
  • Thanks @ihemant360 but as I mentionned in the question, I already did it (although I forgot to say that I also cleaned the registry. – Florent May 25 '16 at 8:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.