0

There is an exe file which I cannot run from Explorer, which only alerts me:

Windows cannot access the specified device path or file.
You may not have appropriate permissions to access the item

No matter if I run it as admin or not.

  • Windows 7 Ultimate x64
  • No anti-virus software installed yet
  • UAC is on
  • I own that file
  • I have all permissions on that file (my group Administrators does)
  • I can view the file's content in editor (after UAC dialog)
  • That exe can be successfully executed from a cmd.exe pre-started as admin (but not from Explorer)
  • This all happened after I reinstalled Windows (that file remained from the previous installation)

What may cause the inability to run my own file? How it can be investigated?

screenshots

  • Have you tried starting explorer as administrator? – AFH May 21 '16 at 12:28
  • any update? do you need more help? – magicandre1981 Jul 23 '16 at 8:21
0

You cannot run that file because you don't own it. The owner is probably the account on the other installation that installed the file. Install the program again.

  • 3
    Welcome to Super User! Please read the question again carefully. Your answer does not answer the original question. OP said in the question "I own that file" and it's clear in the screen shot that he does. – DavidPostill May 21 '16 at 11:12
  • I own it. My user name is pasza here. At the previous installation it was different. – Pavel Vlasov May 21 '16 at 11:15
0

As this is fresh installation and the file comes from your previous install....
Are you sure all dependencies for this EXE are already installed ?
In some cases missing dependencies (like VC++ runtimes, certain DLL files) can lead to Windows unable to initialize the EXE in which case (under some rare conditions) it can give the SAME error-message as if the file can't be found.

What it actually means is: I can't find the other file this EXE depends upon.

Unfortunately it doesn't tell you which file it is actually looking for...
In some cases there is also an error-message in the Windows EventLog. That might give some additional information that could be helpful.

  • If dependencies were missing it wouldn't run from cmd, unless the dependent files were in its current directory when the file is launched. – AFH May 21 '16 at 12:26
  • @AFH You're right. I missed that part. Still.. I've seen some cases where the dependency was installed , but the system not rebooted after the install. In that particular case it is possible that the GUI (started before the install of the depenency) doesn't see the dependency yet (reboot required), but CMD.exe (started after install of the dependency) is able to resolve it. A reboot should clear the issue in that case. It is a pretty special corner-case though... – Tonny May 21 '16 at 15:57
0

You have a misunderstanding about permissions in Windows. With UAC on, your account has standard user permissions and so the Shell (Explorer.exe) runs with standard user rights. So you have to edit the permissions for standard user group and give this group full read/write permissions to the directory/exe.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.